Midnight Commander/Libtar Updates for Gentoo
Posted on: 02/21/2014 11:04 AM

The following two updates are available for Gentoo Linux:

[ GLSA 201402-18 ] GNU Midnight Commander: User-assisted execution of arbitrary code
[ GLSA 201402-19 ] libtar: Arbitraty code execution

[ GLSA 201402-18 ] GNU Midnight Commander: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201402-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GNU Midnight Commander: User-assisted execution of arbitrary
code
Date: February 20, 2014
Bugs: #436518
ID: 201402-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

GNU Midnight Commander does not properly sanitize environment
variables, possibly resulting in execution of arbitrary code or Denial
of Service.

Background
==========

GNU Midnight Commander is a text based file manager.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-misc/mc < 4.8.7 >= 4.8.7

Description
===========

GNU Midnight Commander does not properly sanitize environment
variables.

Impact
======

A remote attacker could entice a user to open a specially crafted
archive file using GNU Midnight Commander, possibly resulting in
execution of arbitrary code with the privileges of the process or a
Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GNU Midnight Commander users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-misc/mc-4.8.7"

References
==========

[ 1 ] CVE-2012-4463
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4463

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201402-18.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5





[ GLSA 201402-19 ] libtar: Arbitraty code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201402-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libtar: Arbitraty code execution
Date: February 21, 2014
Bugs: #487420
ID: 201402-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow in libtar might allow remote attackers to execute
arbitrary code or cause a Denial of Service condition.

Background
==========

libtar is a C library for manipulating POSIX tar files.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/libtar < 1.2.20-r2 >= 1.2.20-r2

Description
===========

An integer overflow error within the “th_read()” function when
processing long names or link extensions can be exploited to cause a
heap-based buffer overflow via a specially crafted archive.

Impact
======

A remote attacker could entice a user to open a specially crafted file
using a program linked against libtar, possibly resulting in execution
of arbitrary code with the privileges of the process or a Denial of
Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libtar users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libtar-1.2.20-r2"

References
==========

[ 1 ] CVE-2013-4397
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4397

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201402-19.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/midnight_commanderlibtar_updates_for_gentoo.html)