MDKSA-2005:066 - Updated grip packages
Posted on: 04/02/2005 05:25 AM

Updated grip packages are available for Mandrakelinux
_______________________________________________________________________

Mandrakelinux Security Update Advisory
_______________________________________________________________________

Package name: grip
Advisory ID: MDKSA-2005:066
Date: April 1st, 2005

Affected versions: 10.0, 10.1, Corporate 3.0
______________________________________________________________________

Problem Description:

A buffer overflow bug was found by Dean Brettle in the way that grip handles data returned by CDDB servers. If a user connected to a malicious CDDB server, an attacker could execute arbitrary code on the user's machine.

The updated packages have been patched to correct these issues.

_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0706
______________________________________________________________________

Updated Packages:

Mandrakelinux 10.0:
125e28ae9091cfa5852f89a025a9a886 10.0/RPMS/grip-3.1.4-1.1.100mdk.i586.rpm
b37da3355866e7bcd6dcc99b46b08085 10.0/SRPMS/grip-3.1.4-1.1.100mdk.src.rpm

Mandrakelinux 10.0/AMD64:
dee617d6a08a063365e2e3486e534ded amd64/10.0/RPMS/grip-3.1.4-1.1.100mdk.amd64.rpm
b37da3355866e7bcd6dcc99b46b08085 amd64/10.0/SRPMS/grip-3.1.4-1.1.100mdk.src.rpm

Mandrakelinux 10.1:
53c482bf56570e86946894e50193a869 10.1/RPMS/grip-3.2.0-3.1.101mdk.i586.rpm
051f5840fbc226370bdc6933bdc7de23 10.1/SRPMS/grip-3.2.0-3.1.101mdk.src.rpm

Mandrakelinux 10.1/X86_64:
58ca3a87c97206fe8d0567e3e4660e07 x86_64/10.1/RPMS/grip-3.2.0-3.1.101mdk.x86_64.rpm
051f5840fbc226370bdc6933bdc7de23 x86_64/10.1/SRPMS/grip-3.2.0-3.1.101mdk.src.rpm

Corporate 3.0:
d98c1c3843113b7870da3a78bb13085b corporate/3.0/RPMS/grip-3.1.4-1.1.C30mdk.i586.rpm
cc1f10dd7b4f31e1091cfce12602baa8 corporate/3.0/SRPMS/grip-3.1.4-1.1.C30mdk.src.rpm

Corporate 3.0/X86_64:
bfc65d100286a4fed5c69a5ba2776b95 x86_64/corporate/3.0/RPMS/grip-3.1.4-1.1.C30mdk.x86_64.rpm
cc1f10dd7b4f31e1091cfce12602baa8 x86_64/corporate/3.0/SRPMS/grip-3.1.4-1.1.C30mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrakeUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandrakesoft for security. You can obtain the GPG public key of the Mandrakelinux Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandrakelinux at:

http://www.mandrakesoft.com/security/advisories

If you want to report vulnerabilities, please contact

security_linux-mandrake.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/mdksa_2005066__updated_grip_packages.html)