MDKSA-2005:042 - Updated gpdf packages
Posted on: 02/18/2005 05:33 AM

Updated gpdf packages are available for Mandrakelinux
_______________________________________________________________________

Mandrakelinux Security Update Advisory
_______________________________________________________________________

Package name: gpdf
Advisory ID: MDKSA-2005:042
Date: February 17th, 2005

Affected versions: 10.0, 10.1, Corporate 3.0
______________________________________________________________________

Problem Description:

Previous updates to correct integer overflow issues affecting xpdf overlooked certain conditions when built for a 64 bit platform. (formerly CAN-2004-0888). This also affects applications like gpdf, that use embedded versions of xpdf.

The updated packages are patched to deal with these issues.

_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0206
______________________________________________________________________

Updated Packages:

Mandrakelinux 10.0/AMD64:
d06514c07d91079c76b120d1331d479a amd64/10.0/RPMS/gpdf-0.112-2.6.100mdk.amd64.rpm
e89f8e696edbe10cd00741acca0a75c7 amd64/10.0/SRPMS/gpdf-0.112-2.6.100mdk.src.rpm

Mandrakelinux 10.1/X86_64:
4e492af8918055d5d636de1bc32fa982 x86_64/10.1/RPMS/gpdf-0.132-3.5.101mdk.x86_64.rpm
bd941e699cb9694b94ebae550a462684 x86_64/10.1/SRPMS/gpdf-0.132-3.5.101mdk.src.rpm

Corporate 3.0/X86_64:
6e385cc821332dde1b9c216424eadbbe x86_64/corporate/3.0/RPMS/gpdf-0.112-2.6.C30mdk.x86_64.rpm
44600333f205ef33c9250302fc277c1b x86_64/corporate/3.0/SRPMS/gpdf-0.112-2.6.C30mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrakeUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandrakesoft for security. You can obtain the GPG public key of the Mandrakelinux Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandrakelinux at:

http://www.mandrakesoft.com/security/advisories

If you want to report vulnerabilities, please contact

security_linux-mandrake.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/mdksa_2005042__updated_gpdf_packages.html)