MDKSA-2005:032-1 - Updated cpio packages
Posted on: 02/11/2005 05:57 PM

Updated cpio packages are available for Mandrakelinux 10.1
_______________________________________________________________________

Mandrakelinux Security Update Advisory
_______________________________________________________________________

Package name: cpio
Advisory ID: MDKSA-2005:032-1
Date: February 11th, 2005
Original Advisory Date: February 10th, 2005
Affected versions: 10.1
______________________________________________________________________

Problem Description:

A vulnerability in cpio was discovered where cpio would create world- writeable files when used in -o/--create mode and giving an output file (with -O). This would allow any user to modify the created cpio archive. The updated packages have been patched so that cpio now respects the current umask setting of the user.

Update:

The updated cpio packages for 10.1, while they would install with urpmi on the commandline, would not install via rpmdrake. The updated packages correct that.

_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-1999-1572
______________________________________________________________________

Updated Packages:

Mandrakelinux 10.1:
a298815e1095a9d67216de7a03b165fd 10.1/RPMS/cpio-2.5-4.2.101mdk.i586.rpm
803ce098932b51a8c6e67d240b8de436 10.1/SRPMS/cpio-2.5-4.2.101mdk.src.rpm

Mandrakelinux 10.1/X86_64:
294436bfdb9d38edf1e8435ab2875a6a x86_64/10.1/RPMS/cpio-2.5-4.2.101mdk.x86_64.rpm
803ce098932b51a8c6e67d240b8de436 x86_64/10.1/SRPMS/cpio-2.5-4.2.101mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrakeUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandrakesoft for security. You can obtain the GPG public key of the Mandrakelinux Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandrakelinux at:

http://www.mandrakesoft.com/security/advisories

If you want to report vulnerabilities, please contact

security_linux-mandrake.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/mdksa_2005032_1__updated_cpio_packages.html)