MDKSA-2004:118 - Updated perl-Archive-Zip
Posted on: 11/02/2004 06:36 AM

Updated perl-Archive-Zip packages are available for Mandrakelinux 10.1
_______________________________________________________________________

Mandrakelinux Security Update Advisory
_______________________________________________________________________

Package name: perl-Archive-Zip
Advisory ID: MDKSA-2004:118
Date: November 1st, 2004

Affected versions: 10.1
______________________________________________________________________

Problem Description:

Recently, it was noticed that several antivirus programs miss viruses that are contained in ZIP archives with manipulated directory data. The global archive directory of these ZIP file have been manipulated to indicate zero file sizes.

Archive::Zip produces files of zero length when decompressing this type of ZIP file. This causes AV products that use Archive::ZIP to fail to detect viruses in manipulated ZIP archives. One of these products is amavisd-new.

The updated packages are patched to fix this problem.

_______________________________________________________________________

References:

http://rt.cpan.org/NoAuth/Bug.html?id=8077
______________________________________________________________________

Updated Packages:

Mandrakelinux 10.1:
1b0b561bb9766e70bcfd481e25605617 10.1/RPMS/perl-Archive-Zip-1.14-1.0.101mdk.noarch.rpm
c6766a6f3ac0cce36a72e06a1b5f3070 10.1/SRPMS/perl-Archive-Zip-1.14-1.0.101mdk.src.rpm

Mandrakelinux 10.1/X86_64:
527e70bd67497e63ce949ac195d8f28b x86_64/10.1/RPMS/perl-Archive-Zip-1.14-1.0.101mdk.noarch.rpm
c6766a6f3ac0cce36a72e06a1b5f3070 x86_64/10.1/SRPMS/perl-Archive-Zip-1.14-1.0.101mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrakeUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandrakesoft for security. You can obtain the GPG public key of the Mandrakelinux Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandrakelinux at:

http://www.mandrakesoft.com/security/advisories

If you want to report vulnerabilities, please contact

security_linux-mandrake.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/mdksa_2004118__updated_perl_archive_zip.html)