MDKSA-2004:108 - Updated cvs packages
Posted on: 10/20/2004 03:07 AM

Updated cvs packages are available for Mandrakelinux
_______________________________________________________________________

Mandrakelinux Security Update Advisory
_______________________________________________________________________

Package name: cvs
Advisory ID: MDKSA-2004:108
Date: October 19th, 2004

Affected versions: 10.0, 9.2, Corporate Server 2.1
______________________________________________________________________

Problem Description:

iDEFENSE discovered a flaw in CVS versions prior to 1.1.17 in an undocumented switch implemented in CVS' history command. The -X switch specifies the name of the history file which allows an attacker to determine whether arbitrary system files and directories exist and whether or not the CVS process has access to them.

This flaw has been fixed in CVS version 1.1.17.

_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0778
http://www.idefense.com/application/poi/display?id=130type=vulnerabilities
______________________________________________________________________

Updated Packages:

Mandrakelinux 10.0:
90f3a19cde2499b9cf063e209b614ca8 10.0/RPMS/cvs-1.11.17-1.1.100mdk.i586.rpm
fef452d767ce4ed5492ab053e8adea73 10.0/SRPMS/cvs-1.11.17-1.1.100mdk.src.rpm

Mandrakelinux 10.0/AMD64:
97737f9469ad6a56a9c1522d54f60638 amd64/10.0/RPMS/cvs-1.11.17-1.1.100mdk.amd64.rpm
fef452d767ce4ed5492ab053e8adea73 amd64/10.0/SRPMS/cvs-1.11.17-1.1.100mdk.src.rpm

Corporate Server 2.1:
64fd3fdae518ac225bb9453f7cfd7bf9 corporate/2.1/RPMS/cvs-1.11.17-1.1.C21mdk.i586.rpm
3c05bd54940e4539905427223d66fefc corporate/2.1/SRPMS/cvs-1.11.17-1.1.C21mdk.src.rpm

Corporate Server 2.1/x86_64:
91861885c487df19b9b7d903e14bb493 x86_64/corporate/2.1/RPMS/cvs-1.11.17-1.1.C21mdk.x86_64.rpm
3c05bd54940e4539905427223d66fefc x86_64/corporate/2.1/SRPMS/cvs-1.11.17-1.1.C21mdk.src.rpm

Mandrakelinux 9.2:
0a1a9807f647fa1d7614e5434f5aa9cf 9.2/RPMS/cvs-1.11.17-1.1.92mdk.i586.rpm
0a1a9807f647fa1d7614e5434f5aa9cf 9.2/SRPMS/cvs-1.11.17-1.1.92mdk.i586.rpm

Mandrakelinux 9.2/AMD64:
cb5ab2439eff31c6bb50548cddc85a73 amd64/9.2/RPMS/cvs-1.11.17-1.1.92mdk.amd64.rpm
0a1a9807f647fa1d7614e5434f5aa9cf amd64/9.2/SRPMS/cvs-1.11.17-1.1.92mdk.i586.rpm
_______________________________________________________________________

To upgrade automatically use MandrakeUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandrakesoft for security. You can obtain the GPG public key of the Mandrakelinux Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandrakelinux at:

http://www.mandrakesoft.com/security/advisories

If you want to report vulnerabilities, please contact

security_linux-mandrake.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/mdksa_2004108__updated_cvs_packages.html)