MDKSA-2004:041: Updated ProFTPD packages fix vulnerability
Posted on: 05/01/2004 05:27 AM

Updated ProFTPD packages are available for Mandrakelinux
_______________________________________________________________________

Mandrakelinux Security Update Advisory
_______________________________________________________________________

Package name: proftpd
Advisory ID: MDKSA-2004:041
Date: April 30th, 2004

Affected versions: 10.0
______________________________________________________________________

Problem Description:

A portability workaround that was applied in version 1.2.9 of the ProFTPD FTP server caused CIDR based ACL entries in "Allow" and "Deny" directives to act like an "AllowAll" directive. This granted FTP clients access to files and directories that the server configuration may have been explicitly denying.

This problem only exists in version 1.2.9 and has been fixed upstream. A patch has been applied to correct the problem.

_______________________________________________________________________

References:

http://bugs.proftpd.org/show_bug.cgi?id=2267
______________________________________________________________________

Updated Packages:

Mandrakelinux 10.0:
101925465015f7306e3fcf42db6c6c9b 10.0/RPMS/proftpd-1.2.9-3.1.100mdk.i586.rpm
f528f42bb43e0f8cdcb8d6bb43b8c072 10.0/RPMS/proftpd-anonymous-1.2.9-3.1.100mdk.i586.rpm
55c01dbc795e68adde5714b6ebef1c38 10.0/SRPMS/proftpd-1.2.9-3.1.100mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrakeUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

A list of FTP mirrors can be obtained from:

http://www.mandrakesecure.net/en/ftp.php

All packages are signed by Mandrakesoft for security. You can obtain the GPG public key of the Mandrakelinux Security Team by executing:

gpg --recv-keys --keyserver www.mandrakesecure.net 0x22458A98

Please be aware that sometimes it takes the mirrors a few hours to update.


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/mdksa_2004041_updated_proftpd_packages_fix_vulnerability.html)