MDKA-2005:031 - Updated cyrus-sasl packages
Posted on: 06/09/2005 10:07 AM

Updated cyrus-sasl packages are avilable for Mandriva Corporate 3.0
_______________________________________________________________________

Mandriva Linux Update Advisory
_______________________________________________________________________

Package name: cyrus-sasl
Advisory ID: MDKA-2005:031
Date: June 8th, 2005

Affected versions: Corporate 3.0
______________________________________________________________________

Problem Description:

A problem was discovered in saslauthd (part of cyrus-sasl which handles the Simple Authentication and Security Layer (SASL)) when using the LDAP authentication mechanism. If the connection with the LDAP server was torn down (due to an idle timeout, for example), saslauthd would error immediately instead of trying again with the credentials it already has, causing the client application to display an error as if the password was incorrect.

Any administrators relying on saslauthd with LDAP authentication should upgrade their packages.

______________________________________________________________________

Updated Packages:

Corporate 3.0:
c65e6c4459c891c46edfab97fc675e5b corporate/3.0/RPMS/cyrus-sasl-2.1.15-10.4.C30mdk.i586.rpm
fb771251722ba526cec78f015974641f corporate/3.0/RPMS/libsasl2-2.1.15-10.4.C30mdk.i586.rpm
930675963bddfde02a2ff2a11c51908f corporate/3.0/RPMS/libsasl2-devel-2.1.15-10.4.C30mdk.i586.rpm
459f38fc4ef29e361cf4529c309d6207 corporate/3.0/RPMS/libsasl2-plug-anonymous-2.1.15-10.4.C30mdk.i586.rpm
591e34ed39567c2dc76a72355203bc03 corporate/3.0/RPMS/libsasl2-plug-crammd5-2.1.15-10.4.C30mdk.i586.rpm
ae0c8af4813833e917284ed9dcc0180e corporate/3.0/RPMS/libsasl2-plug-digestmd5-2.1.15-10.4.C30mdk.i586.rpm
3d8479383bcdabb9488ec05f23c9971d corporate/3.0/RPMS/libsasl2-plug-gssapi-2.1.15-10.4.C30mdk.i586.rpm
c2c0ecff71244caeb4c9496d6dd65ebf corporate/3.0/RPMS/libsasl2-plug-login-2.1.15-10.4.C30mdk.i586.rpm
75986499bae559f0d81ccaa8338c2fd0 corporate/3.0/RPMS/libsasl2-plug-ntlm-2.1.15-10.4.C30mdk.i586.rpm
1aefa7c4fe11f2f2d6b5bd2b9c479476 corporate/3.0/RPMS/libsasl2-plug-otp-2.1.15-10.4.C30mdk.i586.rpm
82ddb5a30c10feb49e79fd5f19c60536 corporate/3.0/RPMS/libsasl2-plug-plain-2.1.15-10.4.C30mdk.i586.rpm
214a1a65d1653fbd41d3bb72520b9ec0 corporate/3.0/RPMS/libsasl2-plug-sasldb-2.1.15-10.4.C30mdk.i586.rpm
af0e2bca123c6619db24f29789b1bbeb corporate/3.0/RPMS/libsasl2-plug-srp-2.1.15-10.4.C30mdk.i586.rpm
fe1335c41d512172f99093b1e46359d4 corporate/3.0/SRPMS/cyrus-sasl-2.1.15-10.4.C30mdk.src.rpm

Corporate 3.0/X86_64:
542d7f056b3b89f7c992d8993a260d27 x86_64/corporate/3.0/RPMS/cyrus-sasl-2.1.15-10.4.C30mdk.x86_64.rpm
d9dcd91bac2609e956439f5682f931d7 x86_64/corporate/3.0/RPMS/lib64sasl2-2.1.15-10.4.C30mdk.x86_64.rpm
a3fec00f5dbf5a65f4bc0a3895d8514e x86_64/corporate/3.0/RPMS/lib64sasl2-devel-2.1.15-10.4.C30mdk.x86_64.rpm
7cfa6598aef788e956db3dec6c882de7 x86_64/corporate/3.0/RPMS/lib64sasl2-plug-anonymous-2.1.15-10.4.C30mdk.x86_64.rpm
373084c797ed607b6874705b486ce971 x86_64/corporate/3.0/RPMS/lib64sasl2-plug-crammd5-2.1.15-10.4.C30mdk.x86_64.rpm
25d1c25d0820d117adac1266f7fcd997 x86_64/corporate/3.0/RPMS/lib64sasl2-plug-digestmd5-2.1.15-10.4.C30mdk.x86_64.rpm
685392ecdaeeaa548425fdbfa496bf60 x86_64/corporate/3.0/RPMS/lib64sasl2-plug-gssapi-2.1.15-10.4.C30mdk.x86_64.rpm
56e7af60ce8c6c48d1e1616b3e863a3d x86_64/corporate/3.0/RPMS/lib64sasl2-plug-login-2.1.15-10.4.C30mdk.x86_64.rpm

6900ae9c053ee4afb91576f303d90bb5 x86_64/corporate/3.0/RPMS/lib64sasl2-plug-ntlm-2.1.15-10.4.C30mdk.x86_64.rpm
28bf67adf35ff880e07b0b66ea47f474 x86_64/corporate/3.0/RPMS/lib64sasl2-plug-otp-2.1.15-10.4.C30mdk.x86_64.rpm
ebdac3198a8e2a1ae2cefca0ea6c0698 x86_64/corporate/3.0/RPMS/lib64sasl2-plug-plain-2.1.15-10.4.C30mdk.x86_64.rpm
15bdf7a4ea425272f8d3e1e3df04d3ba x86_64/corporate/3.0/RPMS/lib64sasl2-plug-sasldb-2.1.15-10.4.C30mdk.x86_64.rpm
bce0018a755b022192ad7f6d09c0bbb7 x86_64/corporate/3.0/RPMS/lib64sasl2-plug-srp-2.1.15-10.4.C30mdk.x86_64.rpm
fe1335c41d512172f99093b1e46359d4 x86_64/corporate/3.0/SRPMS/cyrus-sasl-2.1.15-10.4.C30mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrakeUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/mdka_2005031__updated_cyrus_sasl_packages.html)