Libsoup2.4 security update for Debian
Posted on: 12/22/2011 11:55 AM

Updated libsoup2.4 packages are available for Debian GNU/Linux

- ---------------------------------------------------------------------------
Debian Security Advisory DSA-2369-1 security@debian.org
http://www.debian.org/security/ Nico Golde
Dec 21th, 2011 http://www.debian.org/security/faq
- ---------------------------------------------------------------------------

Package : libsoup2.4
Vulnerability : insufficient input sanitization
Problem type : remote
Debian-specific: no
Debian bug : 635837
CVE IDs : CVE-2011-2524

It was discovered that libsoup2.4, a HTTP library implementation in C, is
not properly validating input when processing requests made to SoupServer.
A remote attacker can exploit this flaw to access system files via a
directory traversal attack.

For the oldstable distribution (lenny), this problem has been fixed in
version 2.4.1-2+lenny1.

For the stable distribution (squeeze), this problem has been fixed in
version 2.30.2-1+squeeze1.

For the testing distribution (squeeze), this problem has been fixed in
version 2.34.3-1.

For the unstable distribution (sid), this problem has been fixed in
version 2.34.3-1.


We recommend that you upgrade your libsoup2.4 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/libsoup2_4_security_update_for_debian.html)