libgda/libgnomedb 1.9.103 (AKA 2.0 Beta1)
Posted on: 09/04/2006 12:18 PM

libgda/libgnomedb 1.9.103 has been released:

I'm pleased to annouce that the first beta version of libgda/libgnomedb (version 1.9.103) have been released.

libgda/libgnomedb are a complete framewok for developing database-oriented applications, and actually allow access to PostgreSQL, MySQL, Oracle, Sybase, SQLite, FireBird/Interbase, IBM DB2, mSQL and MS SQL server, as well as MS Access and xBase files and ODBC data sources.

libgda/libgnomedb are part of the GNOME Office application suite, providing database access for many features in both Gnumeric and Abiword.

Here is a basic summary of the changes compared with the current stable series:
Compared with the current stable series, this version offers major new
features and corrections:
- added a dictionary object to store all the meta-data regarding a connection (database structure, data types, etc)
- better support of various data models properties (updatable, non
updatable, large result sets)
- new types of data model (to import XML, CSV data and to proxy changes)
- added support for DDL queries (CREATE TABLE, etc)
- usage of per-provider data conversion objects to completely encapsulate the way each DBMS handles data types
- Use generic GValue containers when possible
- new tools

This version is not API compatible with the current stable series.

Tarballs are available at
ftp://ftp.gnome.org/pub/GNOME/sources/libgda/1.9/ and
ftp://ftp.gnome.org/pub/GNOME/sources/libgnomedb/1.9/

To install this new version, you'll need:
* libgda: glib, libxml2, libxslt
* libgnomedb: libgda and dependencies, Gtk+ gt;= 2.6.0, libgnomeui, libglade, gtksourceview



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/libgdalibgnomedb_19103_aka_20_beta1.html)