Krb5 Security Update for openSUSE
Posted on: 10/24/2011 03:06 PM

A Krb5 security update has been released for openSUSE 11.3 and 11.4

openSUSE Security Update: krb5: fixed kdc remote denial of service ( CVE-2011-1528, CVE-2011-1529) and unauthorized file access (CVE-2011-1526)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:1169-1
Rating: important
References: #719393
Cross-References: CVE-2011-1526 CVE-2011-1528 CVE-2011-1529

Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

The following issues have been fixed:

- CVE-2011-1528: In releases krb5-1.8 and later, the KDC
can crash due to an assertion failure.
- CVE-2011-1529: In releases krb5-1.8 and later, the KDC
can crash due to a null pointer dereference.

Both bugs could be triggered by unauthenticated remote
attackers. Additionally CVE-2011-1526 was fixed that
allowed authenticated users to access files via krb5 ftpd
they should not have access to.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch krb5-5303

- openSUSE 11.3:

zypper in -t patch krb5-5303

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

krb5-1.8.3-16.19.1
krb5-appl-clients-1.0-7.10.1
krb5-appl-servers-1.0-7.10.1
krb5-client-1.8.3-16.19.1
krb5-devel-1.8.3-16.19.1
krb5-plugin-kdb-ldap-1.8.3-16.19.1
krb5-plugin-preauth-pkinit-1.8.3-16.19.1
krb5-server-1.8.3-16.19.1

- openSUSE 11.4 (x86_64):

krb5-32bit-1.8.3-16.19.1
krb5-devel-32bit-1.8.3-16.19.1

- openSUSE 11.3 (i586 x86_64):

krb5-1.8.1-5.11.1
krb5-appl-clients-1.0-4.3.1
krb5-appl-servers-1.0-4.3.1
krb5-client-1.8.1-5.11.1
krb5-devel-1.8.1-5.11.1
krb5-plugin-kdb-ldap-1.8.1-5.11.1
krb5-plugin-preauth-pkinit-1.8.1-5.11.1
krb5-server-1.8.1-5.11.1

- openSUSE 11.3 (x86_64):

krb5-32bit-1.8.1-5.11.1
krb5-devel-32bit-1.8.1-5.11.1


References:

http://support.novell.com/security/cve/CVE-2011-1526.html
http://support.novell.com/security/cve/CVE-2011-1528.html
http://support.novell.com/security/cve/CVE-2011-1529.html
https://bugzilla.novell.com/719393



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/krb5_security_update_for_opensuse.html)