Kolab-cyrus-imapd security update for Debian
Posted on: 06/12/2011 12:27 PM

A kolab-cyrus-imapd security update has been released for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2257-1 security@debian.org
http://www.debian.org/security/ Nico Golde
June 11, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : kolab-cyrus-imapd
Vulnerability : implementation error
Problem type : remote
Debian-specific: no
CVE ID : CVE-2011-1926
Debian Bug : 629350

It was discovered that the STARTTLS implementation of the
Kolab Cyrus IMAP server does not properly restrict I/O buffering,
which allows man-in-the-middle attackers to insert commands into encrypted
IMAP, LMTP, NNTP and POP3 sessions by sending a cleartext command that is
processed after TLS is in place.


For the oldstable distribution (lenny), this problem has been fixed in
version 2.2.13-5+lenny3.

For the stable distribution (squeeze), this problem has been fixed in
version 2.2.13-9.1.

For the testing distribution (wheezy), this problem has been fixed in
version 2.2.13p1-0.1.

For the unstable distribution (sid), this problem has been fixed in
version 2.2.13p1-0.1.

We recommend that you upgrade your kolab-cyrus-imapd packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/kolab_cyrus_imapd_security_update_for_debian.html)