Ked/RAR/Ghostscript/Evilvte/Bzip2 Updates for Gentoo Linux
Posted on: 08/21/2017 06:54 AM

The following updates has been released for Gentoo Linux:

GLSA 201708-04 : Ked Password Manager: Information leak
GLSA 201708-05 : RAR and UnRAR: User-assisted execution of arbitrary code
GLSA 201708-06 : GPL Ghostscript: Multiple vulnerabilities
GLSA 201708-07 : evilvte: User-assisted execution of arbitrary code
GLSA 201708-08 : bzip2: Denial of Service

GLSA 201708-04 : Ked Password Manager: Information leak
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201708-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Ked Password Manager: Information leak
Date: August 21, 2017
Bugs: #616690
ID: 201708-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An insecure file usage has been reported in Ked Password Manager
possibly allowing confidential information to be disclosed.

Background
==========

Helps to manage large numbers of passwords and related information and
simplifies the tasks of searching and entering password data.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-admin/kedpm < 0.4.0-r2 Vulnerable!
-------------------------------------------------------------------
NOTE: Certain packages are still vulnerable. Users should migrate
to another package if one is available or wait for the
existing packages to be marked stable by their
architecture maintainers.

Description
===========

A history file in ~/.kedpm/history is written in clear text. All of the
commands performed in the password manager are written there. This can
lead to the disclosure of the master password if the "password" command
is used with an argument. The names of the password entries created and
consulted are also accessible in clear text.

Impact
======

An attacker could obtain confidential information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Gentoo Security recommends that users unmerge Ked Password Manager:

# emerge --unmerge "app-admin/kedpm"

References
==========

[ 1 ] CVE-2017-8296
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8296

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201708-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


GLSA 201708-05 : RAR and UnRAR: User-assisted execution of arbitrary code

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201708-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: RAR and UnRAR: User-assisted execution of arbitrary code
Date: August 21, 2017
Bugs: #622342, #622382
ID: 201708-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An integer overflow in RAR and UnRAR might allow remote attackers to
execute arbitrary code.

Background
==========

RAR and UnRAR provide command line interfaces for compressing and
decompressing RAR files.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-arch/rar < 5.5.0_beta4_p20170628>= 5.5.0_beta4_p20170628
2 app-arch/unrar < 5.5.5 >= 5.5.5
-------------------------------------------------------------------
2 affected packages

Description
===========

A VMSF_DELTA memory corruption was discovered in which an integer
overflow can be caused in DataSize+CurChannel. The result is a negative
value of the "DestPos" variable which allows writing out of bounds when
setting Mem[DestPos].

Impact
======

A remote attacker, by enticing a user to open a specially crafted
archive, could execute arbitrary code with the privileges of the
process.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All RAR users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=app-arch/rar-5.5.0_beta4_p20170628"

All UnRAR users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/unrar-5.5.5"

References
==========

[ 1 ] CVE-2012-6706
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-6706

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201708-05

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


GLSA 201708-06 : GPL Ghostscript: Multiple vulnerabilities

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201708-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GPL Ghostscript: Multiple vulnerabilities
Date: August 21, 2017
Bugs: #616814, #617016, #617018, #617020, #617022, #618818
ID: 201708-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in GPL Ghostscript, the worst
of which can resulting in the execution of arbitrary code.

Background
==========

Ghostscript is an interpreter for the PostScript language and for PDF.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-text/ghostscript-gpl
< 9.21 >= 9.21

Description
===========

Multiple vulnerabilities have been discovered in GPL Ghostscript.
Please review the CVE identifiers referenced below for additional
information.

Impact
======

A context-dependent attacker could entice a user to open a specially
crafted PostScript file or PDF document using GPL Ghostscript possibly
resulting in the execution of arbitrary code with the privileges of the
process or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GPL Ghostscript users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/ghostscript-gpl-9.21"

References
==========

[ 1 ] CVE-2016-10219
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-10219
[ 2 ] CVE-2016-10220
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-10220
[ 3 ] CVE-2017-5951
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5951
[ 4 ] CVE-2017-6196
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-6196
[ 5 ] CVE-2017-7207
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7207
[ 6 ] CVE-2017-8291
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8291

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201708-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


GLSA 201708-07 : evilvte: User-assisted execution of arbitrary code

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201708-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: evilvte: User-assisted execution of arbitrary code
Date: August 21, 2017
Bugs: #611290
ID: 201708-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Improper hypertext validation might allow remote attackers to execute
arbitrary code.

Background
==========

VTE based, highly customizable terminal emulator

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 x11-terms/evilvte < 0.5.1 Vulnerable!
-------------------------------------------------------------------
NOTE: Certain packages are still vulnerable. Users should migrate
to another package if one is available or wait for the
existing packages to be marked stable by their
architecture maintainers.

Description
===========

Steve Kemp of Debian identified a flaw in evilvte which does not
properly validate hypertext links. Please review the Debian bug report
referenced below.

Impact
======

Remote attackers could execute arbitrary code by enticing a user to
click a hyperlink in their terminal.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Gentoo Security recommends that users unmerge evilvte:

# emerge --unmerge "x11-terms/evilvte"

References
==========

[ 1 ] Debian Bug #854585
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854585

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201708-07

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


GLSA 201708-08 : bzip2: Denial of Service

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201708-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: bzip2: Denial of Service
Date: August 21, 2017
Bugs: #620466
ID: 201708-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An use-after-free vulnerability has been found in bzip2 that could
allow remote attackers to cause a Denial of Service condition.

Background
==========

bzip2 is a high-quality data compressor used extensively by Gentoo
Linux.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-arch/bzip2 < 1.0.6-r8: >= 1.0.6-r8:

Description
===========

A use-after-free flaw was found in bzip2recover, leading to a null
pointer dereference, or a write to a closed file descriptor. Please
review the CVE identifier referenced below for details.

Impact
======

A remote attacker could entice a user to process a specially crafted
bzip2 archive using bzip2recover, possibly resulting in a Denial of
Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All bzip2 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/bzip2-1.0.6-r8"

References
==========

[ 1 ] CVE-2016-3189
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3189

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201708-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5





Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/kedrarghostscriptevilvtebzip2_updates_for_gentoo_linux.html)