KDE Security Advisory: multiple buffer overflows in kpdf/koffice
Posted on: 12/08/2005 10:44 AM

KDE Security Advisory: kpdf/xpdf multiple integer overflows
Original Release Date: 2005-12-07
URL: http://www.kde.org/info/security/advisory-20051207-1.txt

0. References
CAN-2005-3191
CAN-2005-3192
CAN-2005-3193

1. Systems affected:

KDE 3.2.0 up to including KDE 3.5.0
KOffice 1.3.0 up to including KOffice 1.4.2

2. Overview:

kpdf, the KDE pdf viewer, shares code with xpdf. xpdf contains
multiple integer overflow vulnerabilities that allow specially
crafted pdf files, when opened, to overflow a heap allocated
buffer and execute arbitrary code.

3. Impact:

Remotely supplied pdf files can be used to execute arbitrary
code on the client machine.

4. Solution:

Source code patches have been made available which fix these
vulnerabilities. Contact your OS vendor / binary package provider
for information about how to obtain updated binary packages.

5. Patch:

Patch for KDE 3.5.0 is available from
ftp://ftp.kde.org/pub/kde/security_patches :
04d1a115cca0deacbfca5c172bb9f4db

post-3.5.0-kdegraphics-CAN-2005-3193.diff

Patch for KDE 3.4.3 is available from
ftp://ftp.kde.org/pub/kde/security_patches :
b9787ff17e3e7eccee9ff23edcdca2c1

post-3.4.3-kdegraphics-CAN-2005-3193.diff

Patch for KDE 3.3.2 is available from
ftp://ftp.kde.org/pub/kde/security_patches :
8e0b2db76bc419b444f8308b3d8127b9 post-3.3.2-kdegraphics-CAN-2005-3193.diff

Patch for KDE 3.2.3 is available from
ftp://ftp.kde.org/pub/kde/security_patches :
75c90ff2998ff7b4c1b66fbf85d351f1

post-3.2.3-kdegraphics-CAN-2005-3193.diff
Patch for KOffice 1.3.0 and newer is available from
ftp://ftp.kde.org/pub/kde/security_patches :
e663d0b1b6c32c3fb99c85834ae7b17b post-1.3-koffice-CAN-2005-3193.diff


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/kde_security_advisory_multiple_buffer_overflows_in_kpdfkoffice.html)