Java/LibXML2 Updates for RHEL
Posted on: 09/19/2012 09:10 AM

The following two updates has been released for RHEL: [RHSA-2012:1289-01] Critical: java-1.7.0-ibm security update and [RHSA-2012:1288-01] Moderate: libxml2 security update

[RHSA-2012:1289-01] Critical: java-1.7.0-ibm security update
=====================================================================
Red Hat Security Advisory

Synopsis: Critical: java-1.7.0-ibm security update
Advisory ID: RHSA-2012:1289-01
Product: Red Hat Enterprise Linux Extras
Advisory URL: https://rhn.redhat.com/errata/RHSA-2012-1289.html
Issue date: 2012-09-18
CVE Names: CVE-2012-0547 CVE-2012-0551 CVE-2012-1682
CVE-2012-1713 CVE-2012-1716 CVE-2012-1717
CVE-2012-1719 CVE-2012-1721 CVE-2012-1722
CVE-2012-1725 CVE-2012-1726 CVE-2012-3136
CVE-2012-4681
=====================================================================

1. Summary:

Updated java-1.7.0-ibm packages that fix several security issues are now
available for Red Hat Enterprise Linux 6 Supplementary.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Desktop Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux HPC Node Supplementary (v. 6) - x86_64
Red Hat Enterprise Linux Server Supplementary (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Workstation Supplementary (v. 6) - i386, x86_64

3. Description:

IBM Java SE version 7 includes the IBM Java Runtime Environment and the IBM
Java Software Development Kit.

This update fixes several vulnerabilities in the IBM Java Runtime
Environment and the IBM Java Software Development Kit. Detailed
vulnerability descriptions are linked from the IBM Security alerts page,
listed in the References section. (CVE-2012-0547, CVE-2012-0551,
CVE-2012-1682, CVE-2012-1713, CVE-2012-1716, CVE-2012-1717, CVE-2012-1719,
CVE-2012-1721, CVE-2012-1722, CVE-2012-1725, CVE-2012-1726, CVE-2012-3136,
CVE-2012-4681)

All users of java-1.7.0-ibm are advised to upgrade to these updated
packages, containing the IBM Java SE 7 SR2 release. All running instances
of IBM Java must be restarted for the update to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/knowledge/articles/11258

5. Bugs fixed (http://bugzilla.redhat.com/):

829358 - CVE-2012-1717 OpenJDK: insecure temporary file permissions (JRE, 7143606)
829360 - CVE-2012-1716 OpenJDK: SynthLookAndFeel application context bypass (Swing, 7143614)
829361 - CVE-2012-1713 OpenJDK: fontmanager layout lookup code memory corruption (2D, 7143617)
829371 - CVE-2012-1719 OpenJDK: mutable repository identifiers in generated stub code (CORBA, 7143851)
829376 - CVE-2012-1725 OpenJDK: insufficient invokespecial verification (HotSpot, 7160757)
829377 - CVE-2012-1726 OpenJDK: java.lang.invoke.MethodHandles.Lookup does not honor access modes (Libraries, 7165628)
831353 - CVE-2012-1721 Oracle JDK: unspecified vulnerability fixed in 6u33 and 7u5 (Deployment)
831354 - CVE-2012-1722 Oracle JDK: unspecified vulnerability fixed in 6u33 and 7u5 (Deployment)
831355 - CVE-2012-0551 Oracle JDK: unspecified vulnerability fixed in 6u33 and 7u5 (Deployment)
852051 - CVE-2012-4681 OpenJDK: beans insufficient permission checks, Java 7 0day (beans, 7162473)
853097 - CVE-2012-1682 OpenJDK: beans ClassFinder insufficient permission checks (beans, 7162476)
853138 - CVE-2012-3136 OpenJDK: beans MethodElementHandler insufficient permission checks (beans, 7194567)
853228 - CVE-2012-0547 OpenJDK: AWT hardening fixes (AWT, 7163201)

6. Package List:

Red Hat Enterprise Linux Desktop Supplementary (v. 6):

i386:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-jdbc-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-plugin-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.i686.rpm

x86_64:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-jdbc-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-plugin-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm

Red Hat Enterprise Linux HPC Node Supplementary (v. 6):

x86_64:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm

Red Hat Enterprise Linux Server Supplementary (v. 6):

i386:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-jdbc-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-plugin-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.i686.rpm

ppc64:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.ppc64.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.ppc64.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.ppc64.rpm
java-1.7.0-ibm-jdbc-1.7.0.2.0-1jpp.3.el6_3.ppc64.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.ppc64.rpm

s390x:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.s390x.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.s390x.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.s390x.rpm
java-1.7.0-ibm-jdbc-1.7.0.2.0-1jpp.3.el6_3.s390x.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.s390x.rpm

x86_64:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-jdbc-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-plugin-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm

Red Hat Enterprise Linux Workstation Supplementary (v. 6):

i386:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-jdbc-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-plugin-1.7.0.2.0-1jpp.3.el6_3.i686.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.i686.rpm

x86_64:
java-1.7.0-ibm-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-demo-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-devel-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-jdbc-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-plugin-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm
java-1.7.0-ibm-src-1.7.0.2.0-1jpp.3.el6_3.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2012-0547.html
https://www.redhat.com/security/data/cve/CVE-2012-0551.html
https://www.redhat.com/security/data/cve/CVE-2012-1682.html
https://www.redhat.com/security/data/cve/CVE-2012-1713.html
https://www.redhat.com/security/data/cve/CVE-2012-1716.html
https://www.redhat.com/security/data/cve/CVE-2012-1717.html
https://www.redhat.com/security/data/cve/CVE-2012-1719.html
https://www.redhat.com/security/data/cve/CVE-2012-1721.html
https://www.redhat.com/security/data/cve/CVE-2012-1722.html
https://www.redhat.com/security/data/cve/CVE-2012-1725.html
https://www.redhat.com/security/data/cve/CVE-2012-1726.html
https://www.redhat.com/security/data/cve/CVE-2012-3136.html
https://www.redhat.com/security/data/cve/CVE-2012-4681.html
https://access.redhat.com/security/updates/classification/#critical
https://www.ibm.com/developerworks/java/jdk/alerts/

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.

[RHSA-2012:1288-01] Moderate: libxml2 security update
=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: libxml2 security update
Advisory ID: RHSA-2012:1288-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2012-1288.html
Issue date: 2012-09-18
CVE Names: CVE-2011-3102 CVE-2012-2807
=====================================================================

1. Summary:

Updated libxml2 packages that fix multiple security issues are now
available for Red Hat Enterprise Linux 5 and 6.

The Red Hat Security Response Team has rated this update as having moderate
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

RHEL Desktop Workstation (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux Desktop (v. 6) - i386, x86_64
Red Hat Enterprise Linux Desktop Optional (v. 6) - i386, x86_64
Red Hat Enterprise Linux HPC Node (v. 6) - x86_64
Red Hat Enterprise Linux HPC Node Optional (v. 6) - x86_64
Red Hat Enterprise Linux Server (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Server Optional (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Workstation (v. 6) - i386, x86_64
Red Hat Enterprise Linux Workstation Optional (v. 6) - i386, x86_64

3. Description:

The libxml2 library is a development toolbox providing the implementation
of various XML standards.

Multiple integer overflow flaws, leading to heap-based buffer overflows,
were found in the way libxml2 handled documents that enable entity
expansion. A remote attacker could provide a large, specially-crafted XML
file that, when opened in an application linked against libxml2, would
cause the application to crash or, potentially, execute arbitrary code with
the privileges of the user running the application. (CVE-2012-2807)

A one byte buffer overflow was found in the way libxml2 evaluated certain
parts of XML Pointer Language (XPointer) expressions. A remote attacker
could provide a specially-crafted XML file that, when opened in an
application linked against libxml2, would cause the application to crash
or, potentially, execute arbitrary code with the privileges of the user
running the application. (CVE-2011-3102)

All users of libxml2 are advised to upgrade to these updated packages,
which contain backported patches to correct these issues. The desktop must
be restarted (log out, then log back in) for this update to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/knowledge/articles/11258

5. Bugs fixed (http://bugzilla.redhat.com/):

822109 - CVE-2011-3102 libxml: An off-by-one out-of-bounds write by XPointer part evaluation
835863 - CVE-2012-2807 libxml2 (64-bit): Multiple integer overflows, leading to DoS or possibly other unspecified impact

6. Package List:

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/libxml2-2.6.26-2.1.15.el5_8.5.src.rpm

i386:
libxml2-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-python-2.6.26-2.1.15.el5_8.5.i386.rpm

x86_64:
libxml2-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-2.6.26-2.1.15.el5_8.5.x86_64.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.x86_64.rpm
libxml2-python-2.6.26-2.1.15.el5_8.5.x86_64.rpm

RHEL Desktop Workstation (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/libxml2-2.6.26-2.1.15.el5_8.5.src.rpm

i386:
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.i386.rpm

x86_64:
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.x86_64.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.x86_64.rpm

Red Hat Enterprise Linux (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/libxml2-2.6.26-2.1.15.el5_8.5.src.rpm

i386:
libxml2-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-python-2.6.26-2.1.15.el5_8.5.i386.rpm

ia64:
libxml2-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-2.6.26-2.1.15.el5_8.5.ia64.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.ia64.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.ia64.rpm
libxml2-python-2.6.26-2.1.15.el5_8.5.ia64.rpm

ppc:
libxml2-2.6.26-2.1.15.el5_8.5.ppc.rpm
libxml2-2.6.26-2.1.15.el5_8.5.ppc64.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.ppc.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.ppc64.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.ppc.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.ppc64.rpm
libxml2-python-2.6.26-2.1.15.el5_8.5.ppc.rpm

s390x:
libxml2-2.6.26-2.1.15.el5_8.5.s390.rpm
libxml2-2.6.26-2.1.15.el5_8.5.s390x.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.s390.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.s390x.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.s390.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.s390x.rpm
libxml2-python-2.6.26-2.1.15.el5_8.5.s390x.rpm

x86_64:
libxml2-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-2.6.26-2.1.15.el5_8.5.x86_64.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-debuginfo-2.6.26-2.1.15.el5_8.5.x86_64.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.i386.rpm
libxml2-devel-2.6.26-2.1.15.el5_8.5.x86_64.rpm
libxml2-python-2.6.26-2.1.15.el5_8.5.x86_64.rpm

Red Hat Enterprise Linux Desktop (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Client/en/os/SRPMS/libxml2-2.7.6-8.el6_3.3.src.rpm

i386:
libxml2-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-python-2.7.6-8.el6_3.3.i686.rpm

x86_64:
libxml2-2.7.6-8.el6_3.3.i686.rpm
libxml2-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-python-2.7.6-8.el6_3.3.x86_64.rpm

Red Hat Enterprise Linux Desktop Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Client/en/os/SRPMS/libxml2-2.7.6-8.el6_3.3.src.rpm

i386:
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-devel-2.7.6-8.el6_3.3.i686.rpm
libxml2-static-2.7.6-8.el6_3.3.i686.rpm

x86_64:
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-devel-2.7.6-8.el6_3.3.i686.rpm
libxml2-devel-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-static-2.7.6-8.el6_3.3.x86_64.rpm

Red Hat Enterprise Linux HPC Node (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6ComputeNode/en/os/SRPMS/libxml2-2.7.6-8.el6_3.3.src.rpm

x86_64:
libxml2-2.7.6-8.el6_3.3.i686.rpm
libxml2-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-python-2.7.6-8.el6_3.3.x86_64.rpm

Red Hat Enterprise Linux HPC Node Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6ComputeNode/en/os/SRPMS/libxml2-2.7.6-8.el6_3.3.src.rpm

x86_64:
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-devel-2.7.6-8.el6_3.3.i686.rpm
libxml2-devel-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-static-2.7.6-8.el6_3.3.x86_64.rpm

Red Hat Enterprise Linux Server (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/libxml2-2.7.6-8.el6_3.3.src.rpm

i386:
libxml2-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-devel-2.7.6-8.el6_3.3.i686.rpm
libxml2-python-2.7.6-8.el6_3.3.i686.rpm

ppc64:
libxml2-2.7.6-8.el6_3.3.ppc.rpm
libxml2-2.7.6-8.el6_3.3.ppc64.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.ppc.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.ppc64.rpm
libxml2-devel-2.7.6-8.el6_3.3.ppc.rpm
libxml2-devel-2.7.6-8.el6_3.3.ppc64.rpm
libxml2-python-2.7.6-8.el6_3.3.ppc64.rpm

s390x:
libxml2-2.7.6-8.el6_3.3.s390.rpm
libxml2-2.7.6-8.el6_3.3.s390x.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.s390.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.s390x.rpm
libxml2-devel-2.7.6-8.el6_3.3.s390.rpm
libxml2-devel-2.7.6-8.el6_3.3.s390x.rpm
libxml2-python-2.7.6-8.el6_3.3.s390x.rpm

x86_64:
libxml2-2.7.6-8.el6_3.3.i686.rpm
libxml2-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-devel-2.7.6-8.el6_3.3.i686.rpm
libxml2-devel-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-python-2.7.6-8.el6_3.3.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/libxml2-2.7.6-8.el6_3.3.src.rpm

i386:
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-static-2.7.6-8.el6_3.3.i686.rpm

ppc64:
libxml2-debuginfo-2.7.6-8.el6_3.3.ppc64.rpm
libxml2-static-2.7.6-8.el6_3.3.ppc64.rpm

s390x:
libxml2-debuginfo-2.7.6-8.el6_3.3.s390x.rpm
libxml2-static-2.7.6-8.el6_3.3.s390x.rpm

x86_64:
libxml2-debuginfo-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-static-2.7.6-8.el6_3.3.x86_64.rpm

Red Hat Enterprise Linux Workstation (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Workstation/en/os/SRPMS/libxml2-2.7.6-8.el6_3.3.src.rpm

i386:
libxml2-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-devel-2.7.6-8.el6_3.3.i686.rpm
libxml2-python-2.7.6-8.el6_3.3.i686.rpm

x86_64:
libxml2-2.7.6-8.el6_3.3.i686.rpm
libxml2-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-debuginfo-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-devel-2.7.6-8.el6_3.3.i686.rpm
libxml2-devel-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-python-2.7.6-8.el6_3.3.x86_64.rpm

Red Hat Enterprise Linux Workstation Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Workstation/en/os/SRPMS/libxml2-2.7.6-8.el6_3.3.src.rpm

i386:
libxml2-debuginfo-2.7.6-8.el6_3.3.i686.rpm
libxml2-static-2.7.6-8.el6_3.3.i686.rpm

x86_64:
libxml2-debuginfo-2.7.6-8.el6_3.3.x86_64.rpm
libxml2-static-2.7.6-8.el6_3.3.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2011-3102.html
https://www.redhat.com/security/data/cve/CVE-2012-2807.html
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/javalibxml2_updates_for_rhel.html)