Jackson-databind Security Update for Debian 8/9
Posted on: 11/16/2017 08:39 PM

Updated jackson-databind packages has been released for Debian GNU/Linux 8 and 9

Jackson-databind Security Update for Debian 8/9


- -------------------------------------------------------------------------
Debian Security Advisory DSA-4037-1 security@debian.org
https://www.debian.org/security/ Sebastien Delafond
November 16, 2017 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : jackson-databind
CVE ID : CVE-2017-15095

It was discovered that jackson-databind, a Java library used to parse
JSON and other data formats, improperly validated user input prior to
deserializing: following DSA-4004-1 for CVE-2017-7525, an additional
set of classes was identified as unsafe for deserialization.

For the oldstable distribution (jessie), this problem has been fixed
in version 2.4.2-2+deb8u2.

For the stable distribution (stretch), this problem has been fixed in
version 2.8.6-1+deb9u2.

We recommend that you upgrade your jackson-databind packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/jackson_databind_security_update_for_debian_89.html)