imagemagick (SSA:2006-045-03)
Posted on: 02/15/2006 11:10 AM

New imagemagick packages are available for Slackware 10.2 and -current to fix security issues.

More details about this issue may be found in the Common
Vulnerabilities and Exposures (CVE) database:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4601
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0082

Here are the details from the Slackware 10.2 ChangeLog:
+--------------------------+
patches/packages/imagemagick-6.2.3_3-i486-2.tgz: Patched and
recompiled. Several security issues have been backported to
this release.
For more information, see:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4601
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0082
(* Security fix *)
+--------------------------+


Where to find the new packages:
+-----------------------------+

Updated package for Slackware 10.2:
ftp://ftp.slackware.com/pub/slackware/slackware-10.2/patches/packages/imagemagick-6.2.3_3-i486-2.tgz

Updated package for Slackware -current:
ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/xap/imagemagick-6.2.6_1-i486-1.tgz


MD5 signatures:
+-------------+

Slackware 10.2 package:
e6c8a5775698c4f6fe34f3312a2023e9 imagemagick-6.2.3_3-i486-2.tgz

Slackware -current package:
02980a79f6cbefc33fbba8c2572aee25 imagemagick-6.2.6_1-i486-1.tgz


Installation instructions:
+------------------------+

Upgrade the package as root:
# upgradepkg imagemagick-6.2.3_3-i486-2.tgz


+-----+

Slackware Linux Security Team
http://slackware.com/gpg-key
security@slackware.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/imagemagick_ssa2006_045_03.html)