Icedone/Iceweasel/ffmpeg Updates for Debian
Posted on: 05/14/2012 09:57 AM

The following security updates has been released for Debian GNU/Linux: [SECURITY] [DSA 2457-2] New icedove/iceweasel packages fix regression, and [SECURITY] [DSA-2471-1] ffmpeg security update

[SECURITY] [DSA 2457-2] New icedove/iceweasel packages fix regression
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2457-2 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
May 13, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : iceweasel / icedove
Vulnerability : several
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-0467 CVE-2012-0470 CVE-2012-0471 CVE-2012-0477
CVE-2012-0479

The updates DSA-2457 and DSA-2458 for Iceweasel and Icedove introduced
a regression, which could lead to crashes when interpreting some
Javascript statements.

For the stable distribution (squeeze), this problem has been fixed in
version 3.5.16-15 for Iceweasel and 2.0.11-12 for Icedove.

The unstable distribution (sid) is not affected.

We recommend that you upgrade your iceweasel and icedove packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

[SECURITY] [DSA-2471-1] ffmpeg security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2471-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
May 13, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : ffmpeg
Vulnerability : several
Problem type : local(remote)
Debian-specific: no
CVE ID : CVE-2011-3892 CVE-2011-3893 CVE-2011-3895 CVE-2011-3929
CVE-2011-3936 CVE-2011-3940 CVE-2011-3947 CVE-2012-0853
CVE-2012-0947

Several vulnerabilities have been discovered in FFmpeg, a multimedia
player, server and encoder. Multiple input validations in the decoders/
demuxers for Westwood Studios VQA, Apple MJPEG-B, Theora, Matroska,
Vorbis, Sony ATRAC3, DV, NSV, files could lead to the execution of
arbitrary code.

These issues were discovered by Aki Helin, Mateusz Jurczyk, Gynvael
Coldwind, and Michael Niedermayer.

For the stable distribution (squeeze), this problem has been fixed in
version 4:0.5.8-1.

For the unstable distribution (sid), this problem has been fixed in
version 6:0.8.2-1 of libav.

We recommend that you upgrade your ffmpeg packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/icedoneiceweaselffmpeg_updates_for_debian.html)