gtkmm 2.7.4 and glibmm 2.7.3
Posted on: 08/18/2005 04:28 PM

gtkmm 2.7 wraps new API in GTK+ 2.8, and is API/ABI-compatibile with gtkmm 2.4 and 2.6.

This is the last release before gtkmm 2.8.0, so it's your very last chance to find API problems.

gtkmm stays in-sync with GTK+ by following the official GNOME release schedule:

Bindings for the rest of the GNOME Platform are also available, and are also API-stable.

*** Changes

gtkmm 2.7.4:

* Generated properties accessors.
(Murray Cumming)
* Settings::get_default(): Do not generate
a second wrapper. (Regis Duchesne)
* TreeView: Added unset_model().
* SUN Forte and Tru64 build fixes.
(The Written Word.)
* Documentation fixes. (Jonathon Jongsma)

glibmm 2.7.3:

* Updated reference documentation from glib documentation.

*** Download

You will need libsigc++ 2.0, available here:

*** Development

There is active discussion on the mailing list:
and in the #c++ channel on

Printed from Linux Compatible (