GnuTLS/Lighttpd Updates for Gentoo
Posted on: 06/14/2014 06:58 AM

The following two security updates has been released for Gentoo Linux:

[ GLSA 201406-09 ] GnuTLS: Multiple vulnerabilities
[ GLSA 201406-10 ] lighttpd: Multiple vulnerabilities

[ GLSA 201406-09 ] GnuTLS: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201406-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GnuTLS: Multiple vulnerabilities
Date: June 13, 2014
Bugs: #501282, #503394, #511840
ID: 201406-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in GnuTLS, the worst of
which could lead to arbitrary code execution.

Background
==========

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0
protocols.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-libs/gnutls < 2.12.23-r6 >= 2.12.23-r6

Description
===========

Multiple vulnerabilities have been discovered in GnuTLS. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could utilize multiple vectors to spoof arbitrary SSL
servers via a crafted certificate, execute arbitrary code or cause a
Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GnuTLS users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.23-r6"

References
==========

[ 1 ] CVE-2014-0092
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0092
[ 2 ] CVE-2014-1959
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1959
[ 3 ] CVE-2014-3465
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3465
[ 4 ] CVE-2014-3466
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3466

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201406-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5





[ GLSA 201406-10 ] lighttpd: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201406-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: lighttpd: Multiple vulnerabilities
Date: June 13, 2014
Bugs: #392581, #444179, #490432, #491154, #504330
ID: 201406-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in lighttpd, allowing remote
attackers cause a Denial of Service condition or execute arbitrary SQL
statements.

Background
==========

lighttpd is a lightweight high-performance web server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-servers/lighttpd < 1.4.35 >= 1.4.35

Description
===========

Multiple vulnerabilities have been discovered in lighttpd. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could create a Denial of Service condition.
Futhermore, a remote attacker may be able to execute arbitrary SQL
statements.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All lighttpd users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/lighttpd-1.4.35"

References
==========

[ 1 ] CVE-2011-4362
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4362
[ 2 ] CVE-2012-5533
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-5533
[ 3 ] CVE-2013-4508
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4508
[ 4 ] CVE-2013-4559
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4559
[ 5 ] CVE-2013-4560
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4560
[ 6 ] CVE-2014-2323
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2323

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201406-10.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/gnutlslighttpd_updates_for_gentoo.html)