gnupg (SSA:2006-340-01)
Posted on: 12/07/2006 12:42 PM

New gnupg packages are available for Slackware 9.0, 9.1, 10.0, 10.1, 10.2, and 11.0 to fix security issues.

More details about the issues may be found here:

Here are the details from the Slackware 11.0 ChangeLog:
Upgraded to gnupg-1.4.6. This release fixes a severe and exploitable
bug in earlier versions of gnupg. All gnupg users should update to the
new packages as soon as possible. For details, see the information
concerning CVE-2006-6235 posted on
The CVE entry for this issue may be found here:
This update also addresses a more minor security issue possibly
exploitable when GnuPG is used in interactive mode. For more information
about that issue, see:
(* Security fix *)

Where to find the new packages:

HINT: Getting slow download speeds from Give a try. This is another primary FTP site for Slackware that can be considerably faster than downloading from

Thanks to the friendly folks at the OSU Open Source Lab ( for donating additional FTP and rsync hosting to the Slackware project! :-)

Also see the "Get Slack" section on for additional mirror sites near you.

Updated package for Slackware 9.0:

Updated package for Slackware 9.1:

Updated package for Slackware 10.0:

Updated package for Slackware 10.1:

Updated package for Slackware 10.2:

Updated package for Slackware 11.0:

MD5 signatures:

Slackware 9.0 package:
bc23c2e8fd1862a3749d7ea9478654e2 gnupg-1.4.6-i386-1_slack9.0.tgz

Slackware 9.1 package:
1ec4938e51b300f332696f76ce5476b5 gnupg-1.4.6-i486-1_slack9.1.tgz

Slackware 10.0 package:
8be8d0094be837dca5274c6ef17d0856 gnupg-1.4.6-i486-1_slack10.0.tgz

Slackware 10.1 package:
bdaf8c564a758fb13faecc8f030a8f3c gnupg-1.4.6-i486-1_slack10.1.tgz

Slackware 10.2 package:
1c9e9f1364086ccdb204d50d0ee87df2 gnupg-1.4.6-i486-1_slack10.2.tgz

Slackware 11.0 package:
8f0cd5490e5a12bddc4be418c6806fa3 gnupg-1.4.6-i486-1_slack11.0.tgz

Installation instructions:

Upgrade the package as root:
# upgradepkg gnupg-1.4.6-i486-1_slack11.0.tgz


Slackware Linux Security Team

Printed from Linux Compatible (