GNU TeXmacs/Tomboy Updates for Gentoo
Posted on: 01/26/2014 11:15 AM

The following two security updates are available for Gentoo: [ GLSA 201401-28 ] Tomboy: Privilege escalation and [ GLSA 201401-27 ] GNU TeXmacs: Privilege escalation

[ GLSA 201401-28 ] Tomboy: Privilege escalation
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201401-28
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Tomboy: Privilege escalation
Date: January 26, 2014
Bugs: #356583
ID: 201401-28

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Tomboy could result in privilege escalation.

Background
==========

Tomboy is a desktop note-taking application.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-misc/tomboy < 1.4.2-r1 >= 1.4.2-r1

Description
===========

Tomboy places a zero-length directory name in the LD_LIBRARY_PATH,
which might result in the current working directory (.) to be included
when searching for dynamically linked libraries.

NOTE: This vulnerability exists due to an incomplete fix for
CVE-2005-4790 (GLSA 200711-12).

Impact
======

A local attacker could gain escalated privileges via a specially
crafted shared library.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Tomboy users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-misc/tomboy-1.4.2-r1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since March 02, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-4005
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-4005
[ 2 ] GLSA 200711-12
http://www.gentoo.org/security/en/glsa/glsa-200711-12.xml

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201401-28.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201401-27 ] GNU TeXmacs: Privilege escalation
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201401-27
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: GNU TeXmacs: Privilege escalation
Date: January 26, 2014
Bugs: #337532
ID: 201401-27

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in GNU TeXmacs could result in privilege escalation.

Background
==========

GNU TeXmacs is a free WYSIWYG editing platform with special features
for scientists.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-office/texmacs < 1.0.7.2-r1 >= 1.0.7.2-r1

Description
===========

The texmacs and tm_mupad_help scripts in TeXmacs place a zero-length
directory name in the LD_LIBRARY_PATH, which might result in the
current working directory (.) to be included when searching for
dynamically linked libraries.

Impact
======

A local attacker could gain escalated privileges via a specially
crafted shared library.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GNU TeXmacs users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/texmacs-1.0.7.2-r1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since April 02, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-3394
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2010-3394

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201401-27.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/gnu_texmacstomboy_updates_for_gentoo.html)