GnomePython 2.11.3 (unstable)
Posted on: 07/14/2005 07:58 AM

GnomePython 2.11.3 has been released. This is an unstable release for your testing pleasure.

GnomePython provides python interfacing modules for most of the GNOME Developer Platform libraries (except those already wrapped somewhere else.) Currently the list of provided python modules includes:

- gnome, gnome.ui
- gnomecanvas
- gnomevfs
- gconf
- bonobo, bonobo.activation, bonobo.ui

The source tarball can be found here:
http://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.11/

Please file bug reports (bugs, missing APIs) here:
http://bugzilla.gnome.org/enter_bug.cgi?product=gnome-python

Please note that the API is now frozen for the GNOME 2.12 branch of GnomePython.

Overview of Changes from gnome-python 2.11.2 to gnome-python 2.11.3
==================================================================
* gnomecanvas
- Compilation fixes with libgnomecanvas 2.11.x (Murray Cumming, Gustavo)
- Add canvas-curve.py example demonstrating the use bezier objects
* gconf
- Fix crash when passing the wrong number of arguments to
client.get_pair (Gustavo)
* gnomevfs
- New DNS-SD functions wrapped: dns_sd_browse_sync,
dns_sd_resolve_sync, dns_sd_list_browse_domains_sync, and
get_default_browse_domains (Gustavo)


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/gnomepython_2113_unstable.html)