Gnome2.2 backport for Debian 3.0 download
Posted on: 02/19/2003 06:28 PM

The Gnome2.2 backport for Debian Woody is now available for download:

First of all, a big thanks to all the Debian maintainers for making such good source packages. They did all the real work. Also, thank you DebianPlanet.org for hosting the archive of my gnome2.2 backport for Debian Woody. The upgrade has been smooth for me from gnome 1.4 (woody) as well as from Gustavo Noronha's gnome2 backport.

Add this to your /etc/apt/sources.list:
deb http://mirrors.evilgeniuses.org.uk/debian/backports/woody gnome2.2/
deb-src http://mirrors.evilgeniuses.org.uk/debian/backports/woody gnome2.2/


I recommend exiting gnome if you are currently in it. To install, simply do:
apt-get update
apt-get install gnome-core gdm gtk2-engines*


For the gnome2.2 development packages, you can do:
apt-get install gnome-core-devel

And to pull in various other pieces of gnome software, do:
apt-get install gnome

I have backported gnucash 1.8.1, mozilla 1.2.1, galeon 1.2.7, and evolution 1.2.2 among other things. If you want to upgrade evolution, it is advised that you shutdown evolution and run the killev script.

You can optionally do an 'apt-get -u dist-upgrade' which will pull in all the development support packages that were needed to compile these (eg backported automake, debconf, etc).

These packages were tested on various machines, and appear solid. Bugs should be filed at http://bugzilla.gnome.org unless you think it is a packaging bug (eg it conflicts with other woody packages), in which case send them to me.

If you are interested in how the backport was done, please visit:

http://www.linuxcompatible.org/story.php?id=17145

Potential problem: when logging in for the first time, you may need to run 'fc-cache' from a terminal. This appears to be a fontconfig issue and is not specific to this backport.

Update:
There is a build dependency in libxft2-dev that requires xlibs 4.2.1, however the dependency check when installing libxft2 only checks for xfree86 >= 4.1.0. This allows gnome2.2 to be installed with the 4.1.0 official debs, but X won't start. This has been corrected in a new deb for libxft2 that requires xfree86 4.2.1, and thus prevent gnome2.2 from being installed. The deb should hit the mirrors tomorrow.

You can use these excellent backported 4.2.1 debs:
deb http://people.debian.org/~blade/woody/i386 ./

Add the above to /etc/apt/sources.list
apt-get update apt-get upgrade

Jamie Strandboge
jstrand1@rochester.rr.com


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/gnome22_backport_for_debian_30_download.html)