GLSA 201405-27: LibYAML: Arbitrary code execution
Posted on: 05/23/2014 03:22 PM

A LibYAML update has been released for Gentoo Linux

GLSA 201405-27: LibYAML: Arbitrary code execution


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201405-27
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: LibYAML: Arbitrary code execution
Date: May 23, 2014
Bugs: #505948
ID: 201405-27

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in LibYAML could allow an attacker to execute arbitrary
code or cause a Denial of Service condition.

Background
==========

LibYAML is a YAML 1.1 parser and emitter written in C.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/libyaml < 0.1.6 >= 0.1.6

Description
===========

The yaml_parser_scan_uri_escapes() function does not properly expand
strings passed as input, which can result in a heap-based buffer
overflow.

Impact
======

An attacker could provide a specially-crafted YAML document, which,
when parsed by LibYAML, could result in arbitrary code execution or
cause the application to crash.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All LibYAML users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libyaml-0.1.6"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying these packages.

References
==========

[ 1 ] CVE-2014-2525
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2525

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201405-27.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_201405_27_libyaml_arbitrary_code_execution.html)