GLSA 201205-02: ConnMan: Multiple vulnerabilities
Posted on: 05/16/2012 08:59 AM

A ConnMan security update has been released for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201205-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: ConnMan: Multiple vulnerabilities
Date: May 15, 2012
Bugs: #415415
ID: 201205-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in ConnMan, allowing attackers
to execute arbitrary code or cause Denial of Service.

Background
==========

ConnMan provides a daemon for managing Internet connections.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/connman < 1.0-r1 >= 1.0-r1

Description
===========

Multiple vulnerabilities have been found in ConnMan:

* Errors in inet.c and rtnl.c prevent ConnMan from checking the origin
of netlink messages (CVE-2012-2320).
* ConnMan does not properly check for shell escapes when requesting a
hostname via DHCP (CVE-2012-2321).
* An infinite loop error exists in client.c (CVE-2012-2322).

Impact
======

A remote attacker could execute arbitrary code with the privileges of
the process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ConnMan users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/connman-1.0-r1"

References
==========

[ 1 ] CVE-2012-2320
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2320
[ 2 ] CVE-2012-2321
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2321
[ 3 ] CVE-2012-2322
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2322

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201205-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_201205_02_connman_multiple_vulnerabilities.html)