GLSA 200903-37 Ghostscript: User-assisted execution of arbitrary code
Posted on: 03/24/2009 12:40 AM

A new security update has been released for Gentoo Linux - Ghostscript: User-assisted execution of arbitrary code. Here the announcement:

Gentoo Linux Security Advisory GLSA 200903-37
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Ghostscript: User-assisted execution of arbitrary code
Date: March 23, 2009
Bugs: #261087
ID: 200903-37

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

Multiple integer overflows in the Ghostscript ICC library might allow
for user-assisted execution of arbitrary code.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Ghostscript is an interpreter for the PostScript language and the
Portable Document Format (PDF).

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-text/ghostscript-gpl lt; 8.64-r2 gt;=3D 8.64-r2
2 app-text/ghostscript-gnu lt; 8.62.0 gt;=3D 8.62.0
3 app-text/ghostscript-esp lt;=3D 8.15.4-r1 Vulnerable!
-------------------------------------------------------------------
NOTE: Certain packages are still vulnerable. Users should migrate
to another package if one is available or wait for the
existing packages to be marked stable by their
architecture maintainers.
-------------------------------------------------------------------
3 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Jan Lieskovsky from the Red Hat Security Response Team discovered the
following vulnerabilities in Ghostscript's ICC Library:

* Multiple integer overflows (CVE-2009-0583).

* Multiple insufficient bounds checks on certain variable sizes
(CVE-2009-0584).

Impact
=3D=3D=3D=3D=3D=3D

A remote attacker could entice a user to open a specially crafted
PostScript file containing images and a malicious ICC profile, possibly
resulting in the execution of arbitrary code with the privileges of the
user running the application.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All GPL Ghostscript users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=3Dapp-text/ghostscript-gpl-8.64-r2=
"

All GNU Ghostscript users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=3Dapp-text/ghostscript-gnu-8.62.0"=


We recommend that users unmerge ESP Ghostscript and use GPL or GNU
Ghostscript instead:

# emerge --unmerge "app-text/ghostscript-esp"

For installation instructions, see above.

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

[ 1 ] CVE-2009-0583
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-0583
[ 2 ] CVE-2009-0584
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-0584

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200903-37.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200903_37_ghostscript_user_assisted_execution_of_arbitrary_code.html)