GLSA 200902-05 KTorrent: Multiple vulnerabilitites
Posted on: 02/23/2009 11:45 PM

A new security update has been released for Gentoo Linux - KTorrent: Multiple vulnerabilitites. Here the announcement:

Gentoo Linux Security Advisory GLSA 200902-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: KTorrent: Multiple vulnerabilitites
Date: February 23, 2009
Bugs: #244741
ID: 200902-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two vulnerabilities in the web interface plugin in KTorrent allow for
remote execution of code and arbitrary torrent uploads.

Background
==========

KTorrent is a BitTorrent program for KDE.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-p2p/ktorrent lt; 2.2.8 gt;= 2.2.8

Description
===========

The web interface plugin does not restrict access to the torrent upload
functionality (CVE-2008-5905) and does not sanitize request parameters
properly (CVE-2008-5906) .

Impact
======

A remote attacker could send specially crafted parameters to the web
interface that would allow for arbitrary torrent uploads and remote
code execution with the privileges of the KTorrent process.

Workaround
==========

Disabling the web interface plugin will prevent exploitation of both
issues. Click "Plugins" in the configuration menu and uncheck the
checkbox left of "WebInterface", then apply the changes.

Resolution
==========

All KTorrent users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=net-p2p/ktorrent-2.2.8"

References
==========

[ 1 ] CVE-2008-5905
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5905
[ 2 ] CVE-2008-5906
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5906

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200902-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200902_05_ktorrent_multiple_vulnerabilitites.html)