GLSA 200805-05 Wireshark: Denial of Service
Posted on: 05/08/2008 01:40 AM

A new security update has been released for Gentoo Linux - Wireshark: Denial of Service. Here the announcement:

Gentoo Linux Security Advisory GLSA 200805-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Wireshark: Denial of Service
Date: May 07, 2008
Bugs: #215276
ID: 200805-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple Denial of Service vulnerabilities have been discovered in
Wireshark.

Background
==========

Wireshark is a network protocol analyzer with a graphical front-end.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-analyzer/wireshark lt; 1.0.0 gt;= 1.0.0

Description
===========

Errors exist in:

* the X.509sat dissector because of an uninitialized variable and the
Roofnet dissector because a NULL pointer may be passed to the
g_vsnprintf() function (CVE-2008-1561).

* the LDAP dissector because a NULL pointer may be passed to the
ep_strdup_printf() function (CVE-2008-1562).

* the SCCP dissector because it does not reset a pointer once the
packet has been processed (CVE-2008-1563).

Impact
======

A remote attacker could exploit these vulnerabilities by sending a
malformed packet or enticing a user to read a malformed packet trace
file, causing a Denial of Service.

Workaround
==========

Disable the X.509sat, Roofnet, LDAP, and SCCP dissectors.

Resolution
==========

All Wireshark users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=net-analyzer/wireshark-1.0.0"

References
==========

[ 1 ] CVE-2008-1561
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1561
[ 2 ] CVE-2008-1562
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1562
[ 3 ] CVE-2008-1563
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1563

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200805-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200805_05_wireshark_denial_of_service.html)