GLSA 200804-29 Comix: Multiple vulnerabilities
Posted on: 04/26/2008 12:25 AM

A new security update has been released for Gentoo Linux - Comix: Multiple vulnerabilities. Here the announcement:

Gentoo Linux Security Advisory GLSA 200804-29
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Comix: Multiple vulnerabilities
Date: April 25, 2008
Bugs: #215694
ID: 200804-29

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in Comix may lead to execution of arbitrary
commands and a Denial of Service.

Background
==========

Comix is a GTK comic book viewer.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-gfx/comix lt; 3.6.4-r1 gt;= 3.6.4-r1

Description
===========

Comix does not properly sanitize filenames containing shell
metacharacters when they are passed to the rar, unrar, or jpegtran
programs (CVE-2008-1568). Comix also creates directories with
predictable names (CVE-2008-1796).

Impact
======

A remote attacker could exploit the first vulnerability by enticing a
user to use Comix to open a file with a specially crafted filename,
resulting in the execution of arbitrary commands. The second
vulnerability could be exploited by a local attacker to cause a Denial
of Service by creating a file or directory with the same filename as
the predictable filename used by Comix.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Comix users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=media-gfx/comix-3.6.4-r1"

References
==========

[ 1 ] CVE-2008-1568
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1568
[ 2 ] CVE-2008-1796
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1796

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200804-29.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200804_29_comix_multiple_vulnerabilities.html)