GLSA 200804-24 DBmail: Data disclosure
Posted on: 04/19/2008 12:55 AM

A new security update has been released for Gentoo Linux - DBmail: Data disclosure. Here the announcement:

Gentoo Linux Security Advisory GLSA 200804-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low
Title: DBmail: Data disclosure
Date: April 18, 2008
Bugs: #218154
ID: 200804-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

A vulnerability in DBMail could allow for passwordless login to any
account under certain configurations.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

DBMail is a mail storage and retrieval daemon that uses SQL databases
as its data store. IMAP and POP3 can be used to retrieve mails from the
database.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-mail/dbmail lt; 2.2.9 gt;=3D 2.2.9=


Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

A vulnerability in DBMail's authldap module when used in conjunction
with an Active Directory server has been reported by vugluskr. When
passing a zero length password to the module, it tries to bind
anonymously to the LDAP server. If the LDAP server allows anonymous
binds, this bind succeeds and results in a successful authentication to
DBMail.

Impact
=3D=3D=3D=3D=3D=3D

By passing an empty password string to the server, an attacker could be
able to log in to any account.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All DBMail users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=3Dnet-mail/dbmail-2.2.9"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

[ 1 ] CVE-2007-6714
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2007-6714

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200804-24.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200804_24_dbmail_data_disclosure.html)