GLSA 200803-27 MoinMoin: Multiple vulnerabilities
Posted on: 03/19/2008 12:55 AM

A new security update has been released for Gentoo Linux - MoinMoin: Multiple vulnerabilities. Here the announcement:

Gentoo Linux Security Advisory GLSA 200803-27
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: MoinMoin: Multiple vulnerabilities
Date: March 18, 2008
Bugs: #209133
ID: 200803-27

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Several vulnerabilities have been reported in MoinMoin Wiki Engine.

Background
==========

MoinMoin is an advanced, easy to use and extensible Wiki Engine.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-apps/moinmoin lt; 1.6.1 gt;= 1.6.1

Description
===========

Multiple vulnerabilities have been discovered:

* A vulnerability exists in the file wikimacro.py because the
_macro_Getval function does not properly enforce ACLs
(CVE-2008-1099).

* A directory traversal vulnerability exists in the userform action
(CVE-2008-0782).

* A Cross-Site Scripting vulnerability exists in the login action
(CVE-2008-0780).

* Multiple Cross-Site Scripting vulnerabilities exist in the file
action/AttachFile.py when using the message, pagename, and target
filenames (CVE-2008-0781).

* Multiple Cross-Site Scripting vulnerabilities exist in
formatter/text_gedit.py (aka the gui editor formatter) which can be
exploited via a page name or destination page name, which trigger an
injection in the file PageEditor.py (CVE-2008-1098).

Impact
======

These vulnerabilities can be exploited to allow remote attackers to
inject arbitrary web script or HTML, overwrite arbitrary files, or read
protected pages.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MoinMoin users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=www-apps/moinmoin-1.6.1"

References
==========

[ 1 ] CVE-2008-0780
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0780
[ 2 ] CVE-2008-0781
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0781
[ 3 ] CVE-2008-0782
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0782
[ 4 ] CVE-2008-1098
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1098
[ 5 ] CVE-2008-1099
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1099

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200803-27.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200803_27_moinmoin_multiple_vulnerabilities.html)