GLSA 200803-20 International Components for Unicode: Multiple vulnerabilities
Posted on: 03/11/2008 11:20 PM

A new security update has been released for Gentoo Linux - International Components for Unicode: Multiple vulnerabilities. Here the announcement:

Gentoo Linux Security Advisory GLSA 200803-20
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: International Components for Unicode: Multiple
vulnerabilities
Date: March 11, 2008
Bugs: #208001
ID: 200803-20

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two vulnerabilities have been discovered in the International
Components for Unicode, possibly resulting in the remote execution of
arbitrary code or a Denial of Service.

Background
==========

International Components for Unicode is a set of C/C++ and Java
libraries providing Unicode and Globalization support for software
applications.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/icu lt; 3.8.1-r1 gt;= 3.8.1-r1

Description
===========

Will Drewry (Google Security) reported a vulnerability in the regular
expression engine when using back references to capture \\0 characters
(CVE-2007-4770). He also found that the backtracking stack size is not
limited, possibly allowing for a heap-based buffer overflow
(CVE-2007-4771).

Impact
======

A remote attacker could submit specially crafted regular expressions to
an application using the library, possibly resulting in the remote
execution of arbitrary code with the privileges of the user running the
application or a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All International Components for Unicode users should upgrade to the
latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=dev-libs/icu-3.8.1-r1"

References
==========

[ 1 ] CVE-2007-4770
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4770
[ 2 ] CVE-2007-4771
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4771

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200803-20.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200803_20__international_components_for_unicode_multiple_vulnerabilities.html)