GLSA 200610-09 libmusicbrainz: Multiple buffer overflows
Posted on: 10/22/2006 07:25 PM

A new security update has been released for Gentoo Linux - libmusicbrainz: Multiple buffer overflows. Here the announcement:

Gentoo Linux Security Advisory GLSA 200610-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libmusicbrainz: Multiple buffer overflows
Date: October 22, 2006
Bugs: #144089
ID: 200610-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple buffer overflows have been found in libmusicbrainz, which
could lead to a Denial of Service or possibly the execution of
arbitrary code.

Background
==========

libmusicbrainz is a client library used to access MusicBrainz music
meta data.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/musicbrainz lt; 2.1.4 gt;= 2.1.4=


Description
===========

Luigi Auriemma reported a possible buffer overflow in the
MBHttp: :Download function of lib/http.cpp as well as several possible
buffer overflows in lib/rdfparse.c.

Impact
======

A remote attacker could be able to execute arbitrary code or cause
Denial of Service by making use of an overly long "Location" header in
an HTTP redirect message from a malicious server or a long URL in
malicious RDF feeds.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libmusicbrainz users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=media-libs/musicbrainz-2.1.4=
"

References
==========

[ 1 ] CVE-2006-4197
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4197

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200610-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200610_09_libmusicbrainz_multiple_buffer_overflows.html)