GLSA 200607-13 Audacious: Multiple heap and buffer overflows
Posted on: 07/29/2006 07:42 PM

A new security update has been released for Gentoo Linux - Audacious: Multiple heap and buffer overflows. Here the announcement:

Gentoo Linux Security Advisory GLSA 200607-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Audacious: Multiple heap and buffer overflows
Date: July 29, 2006
Bugs: #139957
ID: 200607-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The adplug library included in Audacious is vulnerable to various
overflows that could result in the execution of arbitrary code.

Background
==========

Audacious is a media player that has been forked from Beep Media
Player.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-sound/audacious lt; 1.1.0 gt;= 1.1.0

Description
===========

Luigi Auriemma has found that the adplug library fails to verify the
size of the destination buffers in the unpacking instructions,
resulting in various possible heap and buffer overflows.

Impact
======

An attacker can entice a user to load a specially crafted media file,
resulting in a crash or possible execution of arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Audacious users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=media-sound/audacious-1.1.0"

References
==========

[ 1 ] BugTraq Announcement
http://www.securityfocus.com/archive/1/439432/30/0/threaded
[ 2 ] CVE-2006-3581
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3581
[ 3 ] CVE-2006-3582
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3582

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200607-13.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200607_13_audacious_multiple_heap_and_buffer_overflows.html)