GLSA 200607-11 TunePimp: Buffer overflow
Posted on: 07/28/2006 11:22 PM

A new security update has been released for Gentoo Linux - TunePimp: Buffer overflow. Here the announcement:

Gentoo Linux Security Advisory GLSA 200607-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: TunePimp: Buffer overflow
Date: July 28, 2006
Bugs: #140184
ID: 200607-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in TunePimp has been reported which could lead to the
execution of arbitrary code.

Background
==========

The TunePimp library (also referred to as libtunepimp) is a development
library geared towards developers who wish to create MusicBrainz
enabled tagging applications.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/tunepimp lt;= 0.4.2 Vulnerable!
-------------------------------------------------------------------
NOTE: Certain packages are still vulnerable. Users should migrate
to another package if one is available or wait for the
existing packages to be marked stable by their
architecture maintainers.

Description
===========

Kevin Kofler has reported a vulnerability where three stack variables
are allocated with 255, 255 and 100 bytes respectively, yet 256 bytes
are read into each. This could lead to buffer overflows.

Impact
======

Running an affected version of TunePimp could lead to the execution of
arbitrary code by a remote attacker.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

TunePimp has been masked in Portage pending the resolution of these
issues. TunePimp users are advised to uninstall the package until
further notice:

# emerge --ask --unmerge "media-libs/tunepimp"

References
==========

[ 1 ] CVE-2006-3600
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3600
[ 2 ] MusicBrainz bug #1764
http://bugs.musicbrainz.org/ticket/1764

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200607-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200607_11_tunepimp_buffer_overflow.html)