GLSA 200607-05 SHOUTcast server: Multiple vulnerabilities
Posted on: 07/09/2006 09:12 PM

A new security update has been released for Gentoo Linux - SHOUTcast server: Multiple vulnerabilities. Here the announcement:

Gentoo Linux Security Advisory GLSA 200607-05
=2D - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
=2D - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: SHOUTcast server: Multiple vulnerabilities
Date: July 09, 2006
Bugs: #136721, #136221
ID: 200607-05

=2D - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

The SHOUTcast server is vulnerable to a file disclosure vulnerability
and multiple XSS vulnerabilities.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

SHOUTcast server is a streaming audio server.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-sound/shoutcast-server-bin lt; 1.9.7 gt;=3D 1.9.7

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

The SHOUTcast server is vulnerable to a file disclosure when the server
receives a specially crafted GET request. Furthermore it also fails to
sanitize the input passed to the "Description", "URL", "Genre", "AIM",
and "ICQ" fields.

Impact
=3D=3D=3D=3D=3D=3D

By sending a specially crafted GET request to the SHOUTcast server, the
attacker can read any file that can be read by the SHOUTcast process.
=46urthermore it is possible that various request variables could also be
exploited to execute arbitrary scripts in the context of a victim's
browser.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All SHOUTcast server users should upgrade to the latest version:

# emerge --sync
#=20
emerge --ask --oneshot --verbose "gt;=3Dmedia-sound/shoutcast-server-bin-1.9.=
7"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

[ 1 ] Original advisory
http://people.ksp.sk/~goober/advisory/001-shoutcast.html
[ 2 ] SA20524
http://secunia.com/advisories/20524/

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200607-05.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200607_05_shoutcast_server_multiple_vulnerabilities.html)