GLSA 200606-18 PAM-MySQL: Multiple vulnerabilities
Posted on: 06/15/2006 08:12 PM

A new security update has been released for Gentoo Linux - PAM-MySQL: Multiple vulnerabilities. Here the announcement:

Gentoo Linux Security Advisory GLSA 200606-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PAM-MySQL: Multiple vulnerabilities
Date: June 15, 2006
Bugs: #120842
ID: 200606-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Vulnerabilities in PAM-MySQL can lead to a Denial of Service, making it
impossible to log into a machine.

Background
==========

PAM-MySQL is a PAM module used to authenticate users against a MySQL
backend.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-auth/pam_mysql lt; 0.7_rc1 gt;= 0.7_rc1

Description
===========

A flaw in handling the result of pam_get_item() as well as further
unspecified flaws were discovered in PAM-MySQL.

Impact
======

By exploiting the mentioned flaws an attacker can cause a Denial of
Service and thus prevent users that authenticate against PAM-MySQL from
logging into a machine. There is also a possible additional attack
vector with more malicious impact that has not been confirmed yet.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PAM-MySQL users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=sys-auth/pam_mysql-0.7_rc1"

References
==========

[ 1 ] Official release information
http://pam-mysql.sourceforge.net/News/

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200606-18.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200606_18_pam_mysql_multiple_vulnerabilities.html)