GLSA 200602-06 ImageMagick: Format string vulnerability
Posted on: 02/13/2006 09:42 PM

A new security update has been released for Gentoo Linux - ImageMagick: Format string vulnerability. Here the announcement:

Gentoo Linux Security Advisory GLSA 200602-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: ImageMagick: Format string vulnerability
Date: February 13, 2006
Bugs: #83542
ID: 200602-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in ImageMagick allows attackers to crash the
application and potentially execute arbitrary code.

Background
==========

ImageMagick is an application suite to manipulate and convert images.
It is often used as a utility backend by web applications like forums,
content management systems or picture galleries.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-gfx/imagemagick lt; 6.2.5.5 gt;= 6.2.5.5

Description
===========

The SetImageInfo function was found vulnerable to a format string
mishandling. Daniel Kobras discovered that the handling of "%"-escaped
sequences in filenames passed to the function is inadequate. This is a
new vulnerability that is not addressed by GLSA 200503-11.

Impact
======

By feeding specially crafted file names to ImageMagick, an attacker can
crash the program and possibly execute arbitrary code with the
privileges of the user running ImageMagick.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ImageMagick users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=media-gfx/imagemagick-6.2.5.5"

References
==========

[ 1 ] CVE-2006-0082
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0082
[ 2 ] GLSA 200503-11
http://www.gentoo.org/security/en/glsa/glsa-200503-11.xml

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200602-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200602_06_imagemagick_format_string_vulnerability.html)