GLSA 200601-03 HylaFAX: Multiple vulnerabilities
Posted on: 01/06/2006 05:52 PM

A new security update has been released for Gentoo Linux - HylaFAX: Multiple vulnerabilities. Here the announcement:

Gentoo Linux Security Advisory GLSA 200601-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: HylaFAX: Multiple vulnerabilities
Date: January 06, 2006
Bugs: #116389
ID: 200601-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

HylaFAX is vulnerable to arbitrary code execution and unauthorized
access vulnerabilities.

Background
==========

HylaFAX is an enterprise-class system for sending and receiving
facsimile messages and for sending alpha-numeric pages.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/hylafax lt; 4.2.3-r1 gt;= 4.2.3-r1

Description
===========

Patrice Fournier discovered that HylaFAX runs the notify script on
untrusted user input. Furthermore, users can log in without a password
when HylaFAX is installed with the pam USE-flag disabled.

Impact
======

An attacker could exploit the input validation vulnerability to run
arbitrary code as the user running HylaFAX, which is usually uucp. The
password vulnerability could be exploited to log in without proper user
credentials.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All HylaFAX users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=net-misc/hylafax-4.2.3-r1"

References
==========

[ 1 ] CVE-2005-3538
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3538
[ 2 ] CVE-2005-3539
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3539
[ 3 ] HylaFAX release announcement
http://www.hylafax.org/content/HylaFAX_4.2.4_release

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200601-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200601_03_hylafax_multiple_vulnerabilities.html)