GLSA 200510-12 KOffice, KWord: RTF import buffer overflow
Posted on: 10/14/2005 01:32 AM

A new security update has been released for Gentoo Linux - KOffice, KWord: RTF import buffer overflow. Here the announcement:

Gentoo Linux Security Advisory GLSA 200510-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: KOffice, KWord: RTF import buffer overflow
Date: October 14, 2005
Bugs: #108411
ID: 200510-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

KOffice and KWord are vulnerable to a buffer overflow in the RTF
importer, potentially resulting in the execution of arbitrary code.

Background
==========

KOffice is an integrated office suite for KDE. KWord is the KOffice
word processor.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-office/koffice lt; 1.4.1-r1 gt;= 1.4.1-r1
2 app-office/kword lt; 1.4.1-r1 gt;= 1.4.1-r1
-------------------------------------------------------------------
2 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
===========

Chris Evans discovered that the KWord RTF importer was vulnerable to a
heap-based buffer overflow.

Impact
======

An attacker could entice a user to open a specially-crafted RTF file,
potentially resulting in the execution of arbitrary code with the
rights of the user running the affected application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All KOffice users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=app-office/koffice-1.4.1-r1"

All KWord users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=app-office/kword-1.4.1-r1"

References
==========

[ 1 ] CAN-2005-2971
http://cve.mitre.org/cgi-bin/cvename.cgi?name 05-2971
[ 2 ] KDE Security Advisory: KWord RTF import buffer overflow
http://www.kde.org/info/security/advisory-20051011-1.txt

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200510-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200510_12_kofficekword_rtf_import_buffer_overflow.html)