GLSA 200506-09: gedit: Format string vulnerability
Posted on: 06/12/2005 05:08 AM

A gedit security update has been released for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200506-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: gedit: Format string vulnerability
Date: June 11, 2005
Bugs: #93352
ID: 200506-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

gedit suffers from a format string vulnerability that could allow arbitrary code execution.

Background
=========

gedit is the official text editor of the GNOME desktop environement.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-editors/gedit lt; 2.10.3 gt;= 2.10.3

Description
==========

A format string vulnerability exists when opening files with names containing format specifiers.

Impact
=====

A specially crafted file with format specifiers in the filename can cause arbitrary code execution.

Workaround
=========

There are no known workarounds at this time.

Resolution
=========

All gedit users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=app-editors/gedit-2.10.3"

References
=========

[ 1 ] BugTraq ID 13699
http://www.securityfocus.com/bid/13699
[ 2 ] gedit 10.3 Release Notes

http://mail.gnome.org/archives/gnome-announce-list/2005-June/msg00006.html

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200506-09.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2005 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200506_09_gedit_format_string_vulnerability.html)