GLSA 200504-16: CVS: Multiple vulnerabilities
Posted on: 04/22/2005 06:29 AM

Another CVS security update is available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory [UPDATE] GLSA 200504-16:02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: CVS: Multiple vulnerabilities
Date: April 18, 2005
Updated: April 21, 2005
Bugs: #86476
ID: 200504-16:02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Update
=====

The initial version did not fix several DoS vulnerabilities and one instance of arbitrary code execution. The arbitrary code execution was only possible under very specific circumstances.

The updated sections appear below.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-util/cvs lt; 1.11.20 gt;= 1.11.20

Description
==========

Alen Zukich has discovered several serious security issues in CVS, including at least one buffer overflow (CAN-2005-0753), memory leaks and a NULL pointer dereferencing error. Furthermore when launching trigger scripts CVS includes a user controlled directory.

Resolution
=========

All CVS users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "gt;=dev-util/cvs-1.11.20"

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200504-16.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2005 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200504_16_cvs_multiple_vulnerabilities_0519.html)