GLSA 200502-14: mod_python: Publisher Handler vulnerability
Posted on: 02/13/2005 04:59 PM

A mod_python security update is available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200502-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low
Title: mod_python: Publisher Handler vulnerability
Date: February 13, 2005
Bugs: #80109
ID: 200502-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

mod_python contains a vulnerability in the Publisher Handler potentially leading to information disclosure.

Background
=========

mod_python is an Apache module that embeds the Python interpreter within the server allowing Python-based web-applications to be created.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-python/mod_python < 3.1.3-r1 >= 3.1.3-r1

Description
==========

Graham Dumpleton discovered a vulnerability in mod_python's Publisher Handler.

Impact
=====

By requesting a specially crafted URL for a published module page, an attacker could obtain information about restricted variables.

Workaround
=========

There is no known workaround at this time.

Resolution
=========

All mod_python users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-python/mod_python-3.1.3-r1"

References
=========

[ 1 ] CAN-2005-0088
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0088

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200502-14.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2005 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200502_14_mod_python_publisher_handler_vulnerability.html)