GLSA 200501-38: Perl: rmtree and DBI tmpfile vulnerabilitie
Posted on: 01/27/2005 06:25 AM

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200501-38
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Perl: rmtree and DBI tmpfile vulnerabilities
Date: January 26, 2005
Bugs: #78634, #75696
ID: 200501-38

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

The Perl DBI library and File::Path::rmtree function are vulnerable to symlink attacks.

Background
=========

Perl is a cross platform programming language. The DBI is the standard database interface module for Perl.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-perl/dbi <= 1.38 *>= 1.37-r1
>= 1.38-r1
2 dev-lang/perl <= 5.8.6-r1 >= 5.8.6-r2
*>= 5.8.5-r3
*>= 5.8.4-r2
*>= 5.8.2-r2
-------------------------------------------------------------------
2 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
==========

Javier Fernandez-Sanguino Pena discovered that the DBI library creates temporary files in an insecure, predictable way (CAN-2005-0077). Paul Szabo found out that "File::Path::rmtree" also handles temporary files insecurely (CAN-2004-0452).

Impact
=====

A local attacker could create symbolic links in the temporary files directory that point to a valid file somewhere on the filesystem. When the DBI library or File::Path::rmtree is executed, this could be used to overwrite files with the rights of the user calling these functions.

Workaround
=========

There are no known workarounds at this time.

Resolution
=========

All Perl users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose dev-lang/perl

All DBI library users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose dev-perl/dbi

References
=========

[ 1 ] CAN-2005-0077
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0077
[ 2 ] CAN-2004-0452
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0452

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200501-38.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2005 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200501_38_perl_rmtree_and_dbi_tmpfile_vulnerabilitie.html)