GLSA 200412-03: imlib: Buffer overflows in image decoding
Posted on: 12/06/2004 11:10 AM

An imlib security update is available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200412-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: imlib: Buffer overflows in image decoding
Date: December 06, 2004
Bugs: #72681
ID: 200412-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

Multiple overflows have been found in the imlib library image decoding routines, potentially allowing execution of arbitrary code.

Background
=========

imlib is an advanced replacement library for image manipulation libraries like libXpm. It is called by numerous programs, including gkrellm and several window managers, to help in displaying images.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/imlib <= 1.9.14-r2 >= 1.9.14-r3

Description
==========

Pavel Kankovsky discovered that several overflows found in the libXpm library (see GLSA 200409-34) also applied to imlib. He also fixed a number of other potential flaws.

Impact
=====

A remote attacker could entice a user to view a carefully-crafted image file, which would potentially lead to execution of arbitrary code with the rights of the user viewing the image. This affects any program that makes use of the imlib library.

Workaround
=========

There is no known workaround at this time.

Resolution
=========

All imlib users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/imlib-1.9.14-r3"

References
=========

[ 1 ] GLSA 200409-34
http://www.gentoo.org/security/en/glsa/glsa-200409-34.xml
[ 2 ] CAN-2004-1026
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1026

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200412-03.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200412_03_imlib_buffer_overflows_in_image_decoding.html)