GLSA 200411-28: X.Org, XFree86: libXpm vulnerabilities
Posted on: 11/19/2004 08:13 PM

A X.Org security update is available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200411-28
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: X.Org, XFree86: libXpm vulnerabilities
Date: November 19, 2004
Bugs: #68544
ID: 200411-28

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

libXpm contains several vulnerabilities that could lead to a Denial of Service and arbitrary code execution.

Background
=========

libXpm is a pixmap manipulation library for the X Window System, included in both X.Org and XFree86.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 x11-base/xorg-x11 < 6.8.0-r3 >= 6.8.0-r3
*>= 6.7.0-r3
2 x11-base/xfree < 4.3.0-r8 >= 4.3.0-r8
-------------------------------------------------------------------
2 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
==========

Several issues were discovered in libXpm, including integer overflows, out-of-bounds memory accesses, insecure path traversal and an endless loop.

Impact
=====

An attacker could craft a malicious pixmap file and entice a user to use it with an application linked against libXpm. This could lead to Denial of Service or arbitrary code execution.

Workaround
=========

There is no known workaround at this time.

Resolution
=========

All X.Org users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-base/xorg-x11-6.7.0-r3"

All XFree86 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-base/xfree-x11-4.3.0-r8"

References
=========

[ 1 ] CAN-2004-0914
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0914

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200411-28.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200411_28_xorgxfree86_libxpm_vulnerabilities.html)