GLSA 200411-03: Apache 1.3: Buffer overflow vulnerability
Posted on: 11/02/2004 10:51 AM

An Apache security update has been released for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200411-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Apache 1.3: Buffer overflow vulnerability in mod_include
Date: November 02, 2004
Bugs: #68564
ID: 200411-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

A buffer overflow vulnerability exists in mod_include which could possibly allow a local attacker to gain escalated privileges.

Background
=========

The Apache HTTP server is one of the most popular web servers on the internet. mod_include is an Apache module to handle Server Side Includes (SSI).

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-www/apache < 1.3.32-r1 >= 1.3.32-r1

Description
==========

A possible buffer overflow exists in the get_tag() function of mod_include.c.

Impact
=====

If Server Side Includes (SSI) are enabled, a local attacker may be able to run arbitrary code with the rights of an httpd child process by making use of a specially-crafted document with malformed SSI.

Workaround
=========

There is no known workaround at this time.

Resolution
=========

All Apache users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-www/apache-1.3.32-r1"

References
=========

[ 1 ] CAN-2004-0940
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0940
[ 2 ] Security vulnerabilities in Apache httpd 1.3
http://www.apacheweek.com/features/security-13

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200411-03.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200411_03_apache_13_buffer_overflow_vulnerability.html)