GLSA 200410-30: GPdf, KPDF, KOffice
Posted on: 10/28/2004 07:55 AM

GPdf, KPDF, and KOffice security updates are available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200410-30
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GPdf, KPDF, KOffice: Vulnerabilities in included xpdf
Date: October 28, 2004
Bugs: #68558, #68665, #68571
ID: 200410-30

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

GPdf, KPDF and KOffice all include vulnerable xpdf code to handle PDF files, making them vulnerable to execution of arbitrary code upon viewing a malicious PDF file.

Background
=========

GPdf is a Gnome-based PDF viewer. KPDF, part of the kdegraphics package, is a KDE-based PDF viewer. KOffice is an integrated office suite for KDE.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-office/koffice < 1.3.3-r1 >= 1.3.3-r1
2 app-text/gpdf < 2.8.0-r1 >= 2.8.0-r1
*>= 0.132-r1
3 kde-base/kdegraphics < 3.3.1-r1 >= 3.3.1-r1
*>= 3.3.0-r1
*>= 3.2.3-r1
-------------------------------------------------------------------
3 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
==========

GPdf, KPDF and KOffice all include xpdf code to handle PDF files. xpdf is vulnerable to multiple integer overflows, as described in GLSA 200410-20.

Impact
=====

An attacker could entice a user to open a specially-crafted PDF file, potentially resulting in execution of arbitrary code with the rights of the user running the affected utility.

Workaround
=========

There is no known workaround at this time.

Resolution
=========

All GPdf users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/gpdf-0.132-r1"

All KDE users should upgrade to the latest version of kdegraphics:

# emerge --sync
# emerge --ask --oneshot --verbose ">=kde-base/kdegraphics-3.3.0-r1"

All KOffice users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/koffice-1.3.3-r1"

References
=========

[ 1 ] GLSA 200410-20
http://www.gentoo.org/security/en/glsa/glsa-200410-20.xml
[ 2 ] CAN-2004-0888
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0888
[ 3 ] CAN-2004-0889
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0889

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200410-30.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200410_30_gpdfkpdfkoffice.html)