GLSA 200410-18: Ghostscript
Posted on: 10/20/2004 06:45 PM

A Ghostscript security update is available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200410-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Ghostscript: Insecure temporary file use in multiple
scripts
Date: October 20, 2004
Bugs: #66357
ID: 200410-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

Multiple scripts in the Ghostscript package are vulnerable to symlink attacks, potentially allowing a local user to overwrite arbitrary files with the rights of the user running the script.

Background
=========

Ghostscript is a software package providing an interpreter for the PostScript language and the PDF file format. It also provides output drivers for various file formats and printers.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-text/ghostscript < 7.07.1-r7 >= 7.07.1-r7
*>= 7.05.6-r2

Description
==========

The pj-gs.sh, ps2epsi, pv.sh and sysvlp.sh scripts create temporary files in world-writeable directories with predictable names.

Impact
=====

A local attacker could create symbolic links in the temporary files directory, pointing to a valid file somewhere on the filesystem. When an affected script is called, this would result in the file to be overwritten with the rights of the user running the script, which could be the root user.

Workaround
=========

There is no known workaround at this time.

Resolution
=========

Ghostscript users on all architectures except PPC should upgrade to the latest version:

# emerge sync

# emerge -pv ">=app-text/ghostscript-7.07.1-r7"
# emerge ">=app-text/ghostscript-7.07.1-r7"

Ghostscript users on the PPC architecture should upgrade to the latest stable version on their architecture:

# emerge sync

# emerge -pv ">=app-text/ghostscript-7.05.6-r2"
# emerge ">=app-text/ghostscript-7.05.6-r2"

References
=========

[ 1 ] CAN-2004-0967
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0967

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200410-18.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200410_18_ghostscript.html)